AWS Security Hub インポートマッピング

  • リリースバージョン: Australia
  • 更新日 2026年04月02日
  • 所要時間:16分
  • AWS Security Hub データマッピングテーブル。

    AWS Security Hub ホスト脆弱性インポート

    データは sn_vul_aws_security_hub_host_vuln_import テーブルにロードされます。

    タイプ 説明
    activity_id 整数 アクティビティ識別子
    activity_name 文字列 アクティビティ名
    category_name 文字列 カテゴリ名
    category_uid 整数 カテゴリの一意の識別子
    class_name 文字列 クラス名
    class_uid 整数 クラスの一意の識別子
    クラウド 文字列 クラウドプロバイダー情報 (JSON)
    finding_info 文字列 情報の検索 (JSON)
    metadata 文字列 メタデータ (JSON)
    是正処置 オブジェクト 修復情報
    リソース 文字列 リソースの詳細 (JSON)
    severity 文字列 重大度レベル
    severity_id 整数 重大度識別子
    status 文字列 検索ステータス
    status_id 整数 ステータス識別子
    time 整数 タイムスタンプ (エポック)
    time_dt 文字列 タイムスタンプ (datetime 文字列)
    type_name 文字列 タイプ名
    type_uid 整数 タイプの一意の識別子
    マップ解除 文字列 マップされていないフィールド
    脆弱性 文字列 脆弱性データ (JSON)
    sys_domain ドメイン ドメインセパレーションのドメイン

    重大度とステータスのマッピング

    表 : 1. AWS Security Hub 重大度マッピング
    AWS Security Hub 重大度 ServiceNow 重大度値 ServiceNow 重大度ラベル
    CRITICAL 1 クリティカル
    HIGH 2
    MEDIUM 3
    LOW 4
    INFORMATIONAL 4
    UNKNOWN 5 なし
    FATAL 1 クリティカル
    OTHER 5 なし
    表 : 2. 検出ステータスマッピング
    AWS Security Hub ステータス ServiceNow 検出ステータス値 ServiceNow 検出ステータスラベル メモ
    新規 0 オープン
    進行中 0 オープン
    解決済み 1 固定
    抑制 0 オープン is_ignored=true を設定します
    アーカイブ済み 1 固定
    不明 0 オープン
    その他 0 オープン
    表 : 3. NVD エントリーフィールドマッピング [sn_vul_nvd_entry]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    vulnerabilities.cve.uid ID CVE 識別子
    「AWS」 ソース AWS ソースを示す静的値
    (参照) aws_cvd_details sn_vul_aws_cvd_attributesを参照するカスタム列
    表 : 4. CVD 属性フィールドマッピング [sn_vul_aws_cvd_attributes]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    cvss[].scoringVector v2_vector_string バージョン 2.x とソースがルートレベルに一致する場合
    cvss[].baseScore score バージョン 2.x の場合
    cvss[].baseScore v3_base_score バージョン 3.x の場合
    cvss[].scoringVector v3_vector_string バージョン 3.x の場合
    cvss[].baseScore v4_base_score バージョン 4.x の場合
    cvss[].scoringVector v4_vector_string バージョン 4.x の場合
    vulnerabilities.is_exploit_available exploit エクスプロイトの可用性
    vulnerabilities.cve.epss.score epss_score EPSS 確率スコア
    vulnerabilities.is_fix_available fix_available 可用性を修正
    脆弱性.重大度 source_severity 致命的/重大→重大、高→高、中→中、低/情報→低、不明/その他→なし
    vulnerabilities.exploit_last_seen_time_dt last_known_exploit_at 前回の既知のエクスプロイト日
    表 : 5. サードパーティ脆弱性エントリーフィールドマッピング [sn_vul_third_party_entry]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    vulnerabilities.cve.uid ID CVE 識別子
    CVSS 重大度 severity CVSS 重大度
    CVSS base_score スコア / v2_base_score / v3_base_score / v4_base_score バージョン依存の基本スコア
    CVSS vector_string v2_vector_string/v3_vector_string/v4_vector_string バージョン依存のベクトル文字列
    vulnerabilities.cve.desc サマリー 脆弱性の説明
    vulnerabilities.cve.modified_time_dt last_modified 最終変更日
    vulnerabilities.cve.created_time_dt date_published 公開日
    vulnerabilities.is_exploit_available exploit エクスプロイトの可用性
    脆弱性.重大度 source_severity ソース重大度
    vulnerabilities.cve.epss.score epss_score EPSS 確率スコア
    vulnerabilities.is_fix_available patch_available パッチの可用性
    vulnerabilities.exploit_last_seen_time_dt last_known_exploit_at 前回の既知のエクスプロイト日
    表 : 6. 検出フィールドマッピング [sn_vul_detection]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    vulnerabilities[0].cve.uid vulnerability 脆弱性エントリーへの参照
    finding_info.title short_description 結果タイトル
    finding_info.desc 説明 検索結果の説明
    finding_info.desc proof 証拠としての説明の検索
    finding_info.first_seen_time_dt first_found 初回確認日のタイムスタンプ
    finding_info.last_seen_time_dt last_found 最後に確認されたタイムスタンプ
    status source_status 新規/処理中/不明/その他→オープン、解決済み→クローズ済み、抑制済み→オープン (is_ignored=true)、アーカイブ済み→クローズ済み
    severity source_severity ソース重大度レベル
    affected_packages[].fixed_in_version fixed_version 影響を受けるパッケージの修正バージョン
    finding_info.uid detection_key 一意の検出キー
    表 : 7. 検出されたアイテムフィールドマッピング [sn_sec_cmn_src_ci]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    resources.uid source_id ソース識別子
    resources.uid resource_id リソース識別子
    resources.region cloud_region AWS リージョン
    resources.owner.account.uid cloud_account AWS アカウント ID
    resources.type cloud_resource_type クラウドリソースタイプ
    「AWS」 cloud_service_provider 静的値:AWS
    「クラウド」 asset_category 静的値:クラウド
    リソース source_data 生ソースデータ
    表 : 8. 脆弱性一致アイテムフィールドマッピング
    AWS Security Hub フィールド ServiceNow フィールド 説明
    status_id state ステータス ID からのステータス
    status status ステータス値
    severity source_severity ソース重大度
    (参照) vulnerability sn_vul_entryへの参照
    (参照) src_ci sn_sec_cmn_src_ciへの参照
    表 : 9. ホスト脆弱性変換スクリプト
    スクリプトのタイミング スクリプト名 説明
    onStart AWSSecurityHubHostVulnerabilitiesProcessor.onStart Security Hub ホスト検出結果のプロセッサを初期化します。
    onBefore AWSSecurityHubHostVulnerabilitiesProcessor.onBefore インポートされた各レコードを処理します。VIT、検出、および検出されたアイテムを作成または更新します。
    onComplete AWSSecurityHubHostVulnerabilitiesProcessor.onComplete インポートとログのサマリー統計情報を確定します。

    AWS Security Hub コンテナ脆弱性インポート

    データが sn_vul_aws_security_hub_container_vuln_import テーブルにロードされます。

    タイプ 説明
    activity_id 整数 アクティビティ識別子
    activity_name 文字列 アクティビティ名
    category_name 文字列 カテゴリ名
    category_uid 整数 カテゴリの一意の識別子
    class_name 文字列 クラス名
    class_uid 整数 クラスの一意の識別子
    クラウド 文字列 クラウドプロバイダー情報 (JSON)
    finding_info 文字列 情報の検索 (JSON)
    metadata 文字列 メタデータ (JSON)
    是正処置 オブジェクト 修復情報
    リソース 文字列 リソースの詳細 (JSON)
    severity 文字列 重大度レベル
    severity_id 整数 重大度識別子
    status 文字列 検索ステータス
    status_id 整数 ステータス識別子
    time 整数 タイムスタンプ (エポック)
    time_dt 文字列 タイムスタンプ (datetime 文字列)
    type_name 文字列 タイプ名
    type_uid 整数 タイプの一意の識別子
    マップ解除 文字列 マップされていないフィールド
    脆弱性 文字列 脆弱性データ (JSON)
    sys_domain ドメイン ドメインセパレーションのドメイン

    コンテナ脆弱性フィールドマッピング

    表 : 10. 検出されたコンテナイメージフィールドマッピング [sn_vul_container_image]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    resources[0].name image_name コンテナイメージ名
    resources[0].image.hash.value image_digest イメージダイジェストハッシュ
    resources[0].image.uid image_id イメージの一意の識別子
    resources[0].image.tag repository_entry イメージタグ
    resources[0].registry_uid レジストリ コンテナレジストリ UID
    cloud.provider cloud_provider クラウドプロバイダー
    cloud.region cloud_region AWS リージョン
    cloud.account.uid cloud_account AWS アカウント ID
    resources[0].repository_name repository リポジトリ名
    表 : 11. コンテナイメージの検出結果フィールドのマッピング
    AWS Security Hub フィールド ServiceNow フィールド 説明
    status state ステータスを検索
    severity severity 結果の重大度
    finding_info.desc proof 証拠としての説明の検索
    finding_info.first_seen_time_dt first_found 初回確認日のタイムスタンプ
    finding_info.last_seen_time_dt last_found 最後に確認されたタイムスタンプ
    status status 検索ステータス
    vulnerabilities.affected_packages[].path path パッケージファイルパス
    表 : 12. コンテナイメージパッケージフィールドマッピング
    AWS Security Hub フィールド ServiceNow フィールド 説明
    vulnerabilities.affected_packages[].name name パッケージ名
    vulnerabilities.affected_packages[].version version パッケージバージョン
    vulnerabilities.affected_packages[].path path パッケージファイルパス
    表 : 13. コンテナ脆弱性一致アイテムフィールドマッピング (CVIT)
    AWS Security Hub フィールド ServiceNow フィールド 説明
    firstObservedAt first_found_dt_tm 初回検出日時
    lastObservedAt last_found_dt_tm 前回検出日時
    status state 状態
    title short_description 簡単な説明
    説明 説明 説明
    vulnerabilities[0].cve.uid vulnerability 脆弱性への参照
    表 : 14. コンテナ脆弱性変換スクリプト
    スクリプトのタイミング スクリプト名 説明
    onStart AWSSecurityHubContainerVulnerabilitiesProcessor.onStart Security Hub コンテナ検索結果のプロセッサを初期化します。
    onBefore AWSSecurityHubContainerVulnerabilitiesProcessor.onBefore インポートされた各コンテナ結果を処理します。CVIT、コンテナイメージ、および検出結果を作成または更新します。
    onComplete AWSSecurityHubContainerVulnerabilitiesProcessor.onComplete コンテナのインポートとログのサマリー統計情報を確定します。

    AWS Security Hub テスト結果のインポート

    データが sn_vul_aws_security_hub_test_results_import テーブルにロードされます。

    タイプ 説明
    activity_id 整数 アクティビティ識別子
    activity_name 文字列 アクティビティ名
    category_name 文字列 カテゴリ名
    category_uid 整数 カテゴリの一意の識別子
    class_name 文字列 クラス名
    class_uid 整数 クラスの一意の識別子
    クラウド 文字列 クラウドプロバイダー情報 (JSON)
    コンプライアンス 文字列 コンプライアンス情報 (JSON)
    finding_info 文字列 情報の検索 (JSON)
    metadata 文字列 メタデータ (JSON)
    是正処置 オブジェクト 修復情報
    リソース 文字列 リソースの詳細 (JSON)
    severity 文字列 重大度レベル
    severity_id 整数 重大度識別子
    status 文字列 検索ステータス
    status_id 整数 ステータス識別子
    time 整数 タイムスタンプ (エポック)
    time_dt 文字列 タイムスタンプ (datetime 文字列)
    type_name 文字列 タイプ名
    type_uid 整数 タイプの一意の識別子
    vendor_attributes 文字列 ベンダー固有の属性 (JSON)
    sys_domain ドメイン ドメインセパレーションのドメイン

    テスト結果フィールドのマッピング

    表 : 15. 信頼できるソースフィールドマッピング [sn_vulc_auth_src]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    「AWS」 ソース 静的ソース値
    compliance.standards source_id コンプライアンス標準識別子
    compliance.standards short_description 表示に使用
    表 : 16. 引用フィールドのマッピング [sn_vulc_citation]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    (参照) コントロール sn_vulc_testへの参照
    「AWS」 ソース 静的ソース値
    コンプライアンス.コントロール section_name コントロールセクション名
    コンプライアンス.コントロール section コントロールセクション
    (参照) auth_src sn_vulc_auth_srcへの参照
    表 : 17. フィールドマッピングのテスト [sn_vulc_test]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    「AWS」 ソース 静的ソース値
    finding_info.title short_description テストの簡単な説明
    finding_info.desc 説明 テストの説明
    finding_info.uid source_id ソース識別子
    finding_info.types source_category ソースカテゴリ
    finding_info.created_time_dt source_created ソース作成日
    finding_info.modified_time_dt source_updated ソース更新日
    severity source_criticality ソース重要度
    remediation.desc 是正処置 是正処置の説明
    表 : 18. テスト結果フィールドマッピング [sn_vulc_result]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    finding_info.first_seen_time_dt first_seen 初回確認日
    finding_info.last_seen_time_dt last_seen 最終確認日
    compliance.status result コンプライアンス結果:合格、失敗、警告、または不明
    vendor_attributes.severity risk_score ベンダーからのリスクスコア
    time_dt last_found_dt_time 前回検出日時
    finding_info.desc 説明 結果の説明
    (参照) コントロール sn_vulc_testへの参照
    表 : 19. テスト結果 CI フィールドマッピング [sn_sec_cmn_src_ci]
    AWS Security Hub フィールド ServiceNow フィールド 説明
    resources.uid source_id ソース識別子
    resources.uid resource_id リソース識別子
    resources.region cloud_region AWS リージョン
    resources.owner.account.uid cloud_account AWS アカウント ID
    resources.type cloud_resource_type クラウドリソースタイプ
    cloud.provider cloud_service_provider クラウドサービスプロバイダー
    「クラウド」 asset_category 静的値:クラウド
    リソース source_data 生ソースデータ
    表 : 20. テスト結果変換スクリプト
    スクリプトのタイミング スクリプト名 説明
    onStart AWSSecurityHubTestResultsProcessor.onStart テスト結果用にプロセッサーを初期化します。
    onBefore AWSSecurityHubTestResultsProcessor.onBefore インポートされた各構成結果を処理します。テスト、テスト結果、および CI を作成または更新します。
    onComplete AWSSecurityHubTestResultsProcessor.onComplete テスト結果のインポートを確定し、サマリー統計情報をログに記録します。