---
sourceDocument: 호주 IT Operations Management
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/ko-KR/it-operations-management

 Release :

    - australia

ft:locale :

    - ko-KR

ft:publication_title :

    - 호주 IT Operations Management

ft:clusterId :

    - itom

bundleId :

    - itom

workflow :

    - Technology


---

# SAP 제품

# SAP 제품 검색 {#ariaid-title1}

* 릴리스 버전: Australia
* 
* 업데이트 날짜 2026년 03월 12일
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 소요 시간: 19분

ITOM 가시성는 SAP 애플리케이션, SAP HANA 데이터베이스 및 SAP HANA DB 카탈로그를 검색할 수 있습니다. 이러한 자원 중 일부를 검색하려면 에서 애플리케이션의 디스커버리 및 서비스 매핑 패턴ServiceNow Store최신 버전으로 업데이트해야 할 수 있습니다.

## ServiceNow® Store에서 새 패턴 또는 향상된 패턴 요청 {#sap-discovery__id_btt_g3g_tzb}

다음을 방문합니다. [ServiceNow Store](https://store.servicenow.com/sn_appstore_store.do#!/store/application/06a71b1367e4130051c9027e2685ef1e/1.6.0?referer=/store/search?listingtype=allintegrations%253Bancillary_app%253Bcertified_apps%253Bcontent%253Bindustry_solution%253Boem%253Butility%253Btemplate&q=Patterns&sl=sh) 사용 가능한 모든 업데이트를 보고 스토어에 요청을 제출하는 방법에 대한 정보를 확인합니다. 출시된 모든 앱의 누적 릴리스 정보는 [ServiceNow Store 버전 이력 릴리스 정보](https://docs.servicenow.com/bundle/store-release-notes/page/release-notes/store/sn-store-release-notes.html).{#sap-discovery__p_d21_nfg_h1c}
검색할 수 있는 구성요소와 해당 버전에 대한 SAP 자세한 내용은 을 참조하십시오 [ITOM 가시성에서 검색한 제품에 대한 상세 정보](https://servicenow-prod.fluidtopics.net/bdRNdUtinuuNNsdd3QdrNg "디스커버리 다양한 서비스 매핑 운영 체제와 애플리케이션을 검색할 수 있습니다.").

## 필수 구성요소 {#sap-discovery__section_msw_rsc_qrb}

애플리케이션이 최신 버전인지 확인
:   디스커버리 및 서비스 매핑 패턴
:   가시성 컨텐츠
:   CMDB CI 클래스 모델

자격 증명 구성 확인
:
    * (UNIX 서버에 호스팅된 경우) ServiceNow AI Platform에서 [애플리케이션 자격 증명](https://www.servicenow.com/docs/access?context=applicative-creds&version=australia&pubname=australia-platform-security&ft:locale=en-US)과 [SSH 자격 증명](https://www.servicenow.com/docs/access?context=r_SSHCredentialsForm&version=australia&pubname=australia-platform-security&ft:locale=en-US)을 구성합니다. SSH 자격 증명은 중앙 인스턴스(CI)에서 SAP 다른 애플리케이션 및 장치로 연결하는 데 사용됩니다. 또한 권한이 있는 사용자가 필요한 명령을 실행할 수 있는 상승된 권한을 사용자에게 제공합니다. [서비스 매핑 권한 있는 사용자가 필요한 명령](https://servicenow-prod.fluidtopics.net/9bEgYXZgHNISMwAwRusvbQ "서비스 매핑 는 조직에서 Unix 기반 호스트를 검색하고 매핑하기 위해 높은 권한이 필요한 명령을 사용합니다. 필요한 자격 증명을 구성하는 것 외에도 조직의 서버에서 이러한 명령을 높은 권한으로 실행할 수 있도록 서비스 매핑 구성합니다.")
    * (서버에 호스팅된 Windows 경우) ServiceNow AI Platform에서 [CI](https://www.servicenow.com/docs/access?context=r_WindowsCredentialsForm&version=australia&pubname=australia-platform-security&ft:locale=en-US) 에서 SAP 다른 애플리케이션 및 장치로 연결하는 Windows 자격 증명을 구성합니다.
    * (선택 사항) WinRM 프로토콜을 사용하여 디스커버리하려면 [MID 서버에서 WinRM 신뢰 호스트 구성](https://www.servicenow.com/docs/access?context=enable-winRM-MID-servers&version=australia&pubname=australia-servicenow-platform&ft:locale=en-US)을 참조하십시오.
    * (서비스 매핑을 통한 하향식 검색의 경우 선택 사항) RFC 읽기 테이블 함수에서 SOAP를 실행할 수 있는 권한을 사용자에게 제공합니다.
    * (서비스 매핑을 통한 하향식 검색의 경우 선택 사항) 조직에서 웹 서비스를 사용하여 SAP 디지털 비즈니스 서비스를 배포하고 연결된 모든 비즈니스 서비스를 매핑하려면 다음 작업을 수행합니다.
      * CVERS, DBCONS 및 RFCDES 테이블에 액세스할 수 있는 권한을 가진 사용자에 대해 애플리케이션 자격 증명을 구성합니다.
      * 웹 서비스 URL이 있는지 확인합니다. 웹 서비스를 생성하는 방법에 대한 자세한 내용은 <https://blogs.sap.com/2012/10/24/how-to-create-web-services-abap-based/>를 참조하십시오.
      {#sap-discovery__ul_y4j_4zy_dfb}
    {#sap-discovery__ul_rt1_frx_mfb}

SAP 의 HANA 2.0 DB 카탈로그 UNIX
:   SAP HANA DB 앱 자격 증명에 대한 애플리케이션 자격 증명이 SAP HANA DB \[cmdb_ci_appl_sap_hana_db\]를 CI 유형으로 구성했는지 확인합니다.

명령을 실행할 서비스 매핑 수 있는 권한 확인
:   [서비스 매핑 권한이 있는 사용자가 필요하지 않은 명령](https://servicenow-prod.fluidtopics.net/Gcvkw4bLhtLubWN5f6neTw "검색 및 매핑에 사용되는 서비스 매핑 대부분의 명령에는 높은 권한이 필요하지 않습니다.")

사용자에게 패턴 쿼리를 실행할 권한이 있는지 확인

:   SAP HANA DB 및 SAP HANA DB 카탈로그 패턴을 실행할 때 다음 명령이 실행됩니다.

    * `스키마에서 *를 선택합니다.`
    * `'%TIMEZONE%'와 같은 upper(KEY)가 있는 M_HOST_INFORMATION에서 * 선택;`
    * `SCHEMA_NAME 선택, 반올림(합계(TABLE_SIZE) /1024/1024) M_TABLES 그룹화 기준 SCHEMA_NAME`
    {#sap-discovery__ul_b1c_4zf_vzb}  
    {#sap-discovery__table_nmf_jcg_vzb__entry__2}

    | 쿼리 유형 | 순서대로 실행된 폴백 명령 |
    |-|-|
    | 스키마 정보 | 1. `$hdbsql_path + " -n " + $entry_point.ip_address + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from schemas;\""` 2. `$hdbsql_path + " -n " + $ip_address + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from schemas;\""` 3. `$hdbsql_path + " -n " + $server_name + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from schemas;\""` 4. `$hdbsql_path + " -n localhost -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from schemas;\""` {#sap-discovery__ol_yqb_lcg_vzb} |
    | 시간대: | 1. `$hdbsql_path + " -n " + $entry_point.ip_address + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from M_HOST_INFORMATION where upper(KEY) like '%TIMEZONE%';\""` 2. `$hdbsql_path + " -n " + $ip_address + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from M_HOST_INFORMATION where upper(KEY) like '%TIMEZONE%';\""` 3. `$hdbsql_path + " -n " + $server_name + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from M_HOST_INFORMATION where upper(KEY) like '%TIMEZONE%';\""` 4. `$hdbsql_path + " -n localhost -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select * from M_HOST_INFORMATION where upper(KEY) like '%TIMEZONE%';\""` {#sap-discovery__ol_hzv_5cg_vzb} |
    | 디스크 크기 | 1. `$hdbsql_path + " -n " + $entry_point.ip_address + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select SCHEMA_NAME, round(sum(TABLE_SIZE) /1024/1024) from M_TABLES GROUP BY SCHEMA_NAME;\""` 2. `$hdbsql_path + " -n " + $ip_address + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select SCHEMA_NAME, round(sum(TABLE_SIZE) /1024/1024) from M_TABLES GROUP BY SCHEMA_NAME;\""` 3. `$hdbsql_path + " -n " + $server_name + ":" + $query_port + " -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select SCHEMA_NAME, round(sum(TABLE_SIZE) /1024/1024) from M_TABLES GROUP BY SCHEMA_NAME;\""` 4. `$hdbsql_path + " -n localhost -i " + $digits + " -u '$$username$$' -p '$$password$$' \"select SCHEMA_NAME, round(sum(TABLE_SIZE) /1024/1024) from M_TABLES GROUP BY SCHEMA_NAME;\""` {#sap-discovery__ol_vpp_bdg_vzb} |
    [ ]

    {#sap-discovery__table_nmf_jcg_vzb}

일정 구성 디스커버리 확인
:   자세한 내용은 [네트워크에서 검색 실행](https://servicenow-prod.fluidtopics.net/_dM9~m0L4bhERP~IhMkl0w "일정 또는 스크립트에서 검색을 실행하여 구성 항목을 생성하거나, 서브넷을 정의 하거나, AWS 및 Azure 클라우드에서 자원을 찾을 수 있습니다.") 문서를 참조하십시오.

## 가로 검색 중 디스커버리에서 수집하는 데이터 {#sap-discovery__section_fyy_5nc_qrb}

{#sap-discovery__table_tvn_14c_qrb__entry__2}

| 테이블 및 필드 | 설명 |
|-|-|
| SAP ASCS \[cmdb_ci_appl_sap_ascs\] ||
| 이름 \[name\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 버전 \[version\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 설치 디렉터리 \[install_directory\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 구성 디렉터리 \[config_directory\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 구성 파일 \[confi_file\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 인스턴스 이름 \[instance_name\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 인스턴스 번호 \[instance_number\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 시스템 ID \[sid\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 시스템 디렉터리 \[system_directory \] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 시스템 유형 \[system_type\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| 전송 도메인 \[transport_domain\] | ABAP Central Services(ASCS)에 대해 SAP 수집된 데이터 |
| SAP 비즈니스 객체 CMS 서버 \[cmdb_ci_appl_sap_bo\] ||
| 이름 \[name\] | 비즈니스 객체 CMS 서버에 대해 SAP 수집된 데이터 |
| 서버 이름 \[server_name\] | 비즈니스 객체 CMS 서버에 대해 SAP 수집된 데이터 |
| 버전 \[version\] | 비즈니스 객체 CMS 서버에 대해 SAP 수집된 데이터 |
| 설치 디렉터리 \[install_directory\] | 비즈니스 객체 CMS 서버에 대해 SAP 수집된 데이터 |
| SAP SCS 애플리케이션 \[cmdb_ci_appl_sap_scs\] ||
| 이름 \[name\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 버전 \[version\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 설치 디렉터리 \[install_directory\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 구성 디렉터리 \[config_directory\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 구성 파일 \[config_file\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 인스턴스 이름 \[instance_name\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 인스턴스 번호 \[instance_number\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 시스템 ID \[sid\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 시스템 디렉터리 \[system_directory\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 시스템 유형 \[system_type\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| 전송 도메인 \[transport_domain\] | 중앙 서비스(SCS)에 대해 SAP 수집된 데이터 |
| SAP CI 애플리케이션 \[cmdb_ci_appl_sap_ci\] ||
| 이름 \[name\] | CI에 대해 SAP 수집된 데이터 |
| 버전 \[version\] | CI에 대해 SAP 수집된 데이터 |
| 설치 디렉터리 \[install_directory\] | CI에 대해 SAP 수집된 데이터 |
| 구성 디렉터리 \[config_directory\] | CI에 대해 SAP 수집된 데이터 |
| 구성 파일 \[config_file\] | CI에 대해 SAP 수집된 데이터 |
| 인스턴스 이름 \[instance_name\] | CI에 대해 SAP 수집된 데이터 |
| 인스턴스 번호 \[instance_number\] | CI에 대해 SAP 수집된 데이터 |
| 시스템 ID \[sid\] | CI에 대해 SAP 수집된 데이터 |
| 시스템 디렉터리 \[system_directory\] | CI에 대해 SAP 수집된 데이터 |
| 시스템 유형 \[system_type\] | CI에 대해 SAP 수집된 데이터 |
| 전송 도메인 \[transport_domain\] | CI에 대해 SAP 수집된 데이터 |
| SAP DI 애플리케이션 \[cmdb_ci_appl_sap_di\] ||
| 이름 \[name\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 버전 \[version\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 설치 디렉터리 \[install_directory\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 구성 디렉터리 \[config_directory\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 구성 파일 \[config_file\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 인스턴스 이름 \[instance_name\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 인스턴스 번호 \[instance_number\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 시스템 ID \[sid\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 시스템 디렉터리 \[system_directory\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 시스템 유형 \[system_type\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| 전송 도메인 \[transport_domain\] | 대화 상자 인스턴스(DI)에 대해 SAP 수집된 데이터 |
| SAP ERS 애플리케이션 \[cmdb_ci_appl_sap_ers\] ||
| 이름 \[name\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 버전 \[version\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 설치 디렉터리 \[install_directory\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 구성 디렉터리 \[config_directory\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 구성 파일 \[config_file\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 인스턴스 이름 \[instance_name\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 인스턴스 번호 \[instance_number\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 시스템 ID \[sid\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 시스템 디렉터리 \[system_directory\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 시스템 유형 \[system_type\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| 전송 도메인 \[transport_domain\] | 큐에 대기 복제 서버(ERS)에 대해 SAP 수집된 데이터 |
| HANA 데이터베이스 \[cmdb_ci_appl_sap_hana_db\] ||
| 이름 \[name\] | HANA 데이터베이스에 대해 SAP 수집된 데이터 |
| IP 주소 \[id_address\] | HANA 데이터베이스에 대해 SAP 수집된 데이터 |
| 클래스 \[sys_class_name\] | HANA 데이터베이스에 대해 SAP 수집된 데이터 |
| 전체 주소 도메인 이름 \[fqdn\] | HANA 데이터베이스에 대해 SAP 수집된 데이터 |
| 버전 \[version\] | HANA 데이터베이스에 대해 SAP 수집된 데이터 |
| 설치 디렉터리 \[install_directory\] | HANA 데이터베이스에 대해 SAP 수집된 데이터 |
| SAP SID \[cmdb_ci_sap_sid\] ||
| 이름 \[name\] | SID(시스템 식별) 코드에 대해 SAP 수집된 데이터는 R/3 설치의 고유 식별 코드입니다 SAP . SID는 D10, PRD 또는 E56과 같은 세 문자로 된 코드입니다. R/3 설치는 데이터베이스 서버와 여러 애플리케이션 서버로 구성됩니다. ITOM 가시성 를 사용합니다.SAP 애플리케이션의 SID를 검색하는 SID 공유 라이브러리 패턴입니다.SAP |
| 버전 \[version\] | SID(시스템 식별) 코드에 대해 SAP 수집된 데이터는 R/3 설치의 고유 식별 코드입니다 SAP . SID는 D10, PRD 또는 E56과 같은 세 문자로 된 코드입니다. R/3 설치는 데이터베이스 서버와 여러 애플리케이션 서버로 구성됩니다. ITOM 가시성 를 사용합니다.SAP 애플리케이션의 SID를 검색하는 SID 공유 라이브러리 패턴입니다.SAP |
| 패치 수준 정보 \[sap_patch_info\] | SID(시스템 식별) 코드에 대해 SAP 수집된 데이터는 R/3 설치의 고유 식별 코드입니다 SAP . SID는 D10, PRD 또는 E56과 같은 세 문자로 된 코드입니다. R/3 설치는 데이터베이스 서버와 여러 애플리케이션 서버로 구성됩니다. ITOM 가시성 를 사용합니다.SAP 애플리케이션의 SID를 검색하는 SID 공유 라이브러리 패턴입니다.SAP |
[ ]

{#sap-discovery__table_tvn_14c_qrb}

## 가로 검색 중 패턴에 HANA UNIX DB 카탈로그에서 수집하는 SAP 데이터 {#sap-discovery__section_rht_nmg_tzb}

{#sap-discovery__table_sx4_3ng_tzb__entry__2}

| 필드 | 설명 |
|-|-|
| 카탈로그 소유자 \[catalog_owner\] | 스키마 소유자의 사용자 ID입니다. |
| 카탈로그 생성 시간 \[catalog_create_time\] | 카탈로그 생성 시간입니다. |
| 할당된 디스크 크기(MB)\[disk_allocated_size_mb\] | 할당된 디스크 크기(MB)입니다. |
| 데이터베이스 참조 \[database_instance\] | SAP HANA DB에 대한 참조입니다. |
[표 1. SAP HANA 카탈로그 \[cmdb_ci_db_hana_catalog\]]

{#sap-discovery__table_sx4_3ng_tzb}

## CI 관계 {#sap-discovery__section_xmm_ynz_qrb}

SID 공유 라이브러리 패턴은 SAP 모든 주요 CI 애플리케이션과 SAP 시스템 ID 간에 CI 관계를 생성합니다.{#sap-discovery__table_jcw_14z_qrb__entry__3}

| CI | 관계 | CI |
|-|-|-|
| SAP ERS 애플리케이션 \[cmdb_ci_appl_sap_ers\] | Uses::Used by | SAP SID \[cmdb_ci_sap_sid\] |
| SAP DI 애플리케이션 \[cmdb_ci_appl_sap_di\] | Uses::Used by | SAP SID \[cmdb_ci_sap_sid\] |
| SAP ASCS \[cmdb_ci_appl_sap_ascs\] | Uses::Used by | SAP SID \[cmdb_ci_sap_sid\] |
| SAP CI 애플리케이션 \[cmdb_ci_appl_sap_ci\] | Uses::Used by | SAP SID \[cmdb_ci_sap_sid\] |
| SAP SCS 애플리케이션 \[cmdb_ci_appl_sap_scs\] | Uses::Used by | SAP SID \[cmdb_ci_sap_sid\] |
| SAP JC 애플리케이션 \[cmdb_ci_appl_sap_jc\] | Uses::Used by | SAP SID \[cmdb_ci_sap_sid\] |
[ ]

{#sap-discovery__table_jcw_14z_qrb}

SAP CI 관계에 대한 UNIX HANA DB 카탈로그
:   {#sap-discovery__table_nqp_34g_tzb__entry__3}

    | CI | 관계 | CI |
    |-|-|-|
    | SAP HANA DB \[cmdb_ci_appl_sap_hana_db\] | Contains::Contained by | SAP HANA DB 카탈로그 \[cmdb_ci_db_hana_catalog\] |
    [ ]

    {#sap-discovery__table_nqp_34g_tzb}

## 제한 {#sap-discovery__section_odz_zwy_dfb}

서비스 매핑 은 배치당 ASCS의 인스턴스를 하나만 매핑할 수 있습니다.

HANA DB 카탈로그 패턴은 SAP 에서만 실행할 UNIX수 있습니다.

## 애플리케이션을 포함하는 SAP 애플리케이션 서비스 매핑 {#ariaid-title2}

애플리케이션을 포함하는 서비스 인스턴스를 SAP 매핑하고 모든 SAP 구성요소가 올바르게 검색되었는지 확인합니다서비스 매핑.

### 시작하기 전에

필요한 역할: service_mapping_admin

### 프로시저

1. 서비스 인스턴스를 생성합니다.
   1. 다음으로 이동 모두서비스 매핑서비스 인스턴스.
   2. 새로 만들기를 선택합니다.  
      서비스 매핑으로 검색 가능 옵션이 기본적으로 선택되어 있습니다.
   3. 이름 필드에 서비스 인스턴스를 설명하는 이름을 입력합니다.
   {#map-service-containing-SAP__substeps_fmn_1by_32b}
2. 이 애플리케이션 서비스의 엔트리포인트를 다음과 같이 정의합니다.
   1. SAP 애플리케이션 타일을 선택합니다.  
      서비스 매핑으로 검색 가능 옵션이 기본적으로 선택되어 있습니다.
   2. 다음과 같이 엔트리포인트를 정의합니다.  
      * 모든 SAP 모듈에 대한 URL
      * 모든 SAP 모듈에 대한 TCP 연결
      * 연결된 서비스가 있는 환경을 검색하려면 다음 형식으로 웹 서비스에 URL을 제공하십시오.

             http://<hostname>:<port>/sap/bc/srt/scs/sap/z_servicenow_read?sap-client=003

      {#map-service-containing-SAP__ul_fk3_mbz_dfb}
   3. 추가를 선택합니다.
   4. 저장을 선택합니다.
   {#map-service-containing-SAP__substeps_iwl_q1z_dfb}
3. 왼쪽에서 추가 정보를 선택하고 트래픽 기반 검색 확인란의 선택을 취소합니다.
4. 업데이트를 선택합니다.
5. 매핑 결과가 올바른지 다음과 같이 확인합니다.
   1. 맵 보기를 선택하고 매핑이 완료될 때까지 기다립니다.  
      이 작업은 몇 분 정도 걸릴 수 있습니다.
   2. 애플리케이션 서비스 맵을 검토하고 서비스 레이아웃이 다음 예시와 같은지 확인합니다.  

      <br />

   {#map-service-containing-SAP__substeps_tzh_ycy_32b}  
   환경에서 구성요소를 Tibco 서비스와 통합하는 SAP 경우 SAP 다음과 같은 매핑 결과를 예상할 수 있습니다.   

## 애플리케이션을 포함하는 SAP 애플리케이션 서비스 문제 해결 {#ariaid-title3}

증상 및 검색 메시지에 따라 기본적인 검색 문제를 해결합니다.

### 증상 {#troubleshoot-services-containing-SAP__section_e2c_bdf_2fb}

의 서비스 매핑 애플리케이션 서비스 맵에는 `<SAP 구성요소 이름>을 검색하지 못했습니다`.

### 원인 {#troubleshoot-services-containing-SAP__section_y4h_lrf_2fb}

CI를 식별하지 못했으며 프로세스 탐지에서 프로세스 속성을 검색합니다.

### 솔루션 {#troubleshoot-services-containing-SAP__section_l1h_mrf_2fb}

다음 단계를 수행합니다.

1. 디버그 모드에서 실패한 패턴 단계를 다음과 같이 엽니다.
   1. 비즈니스 서비스 또는 서비스 인스턴스 맵에서 오류 메시지를 마우스 오른쪽 버튼으로 클릭하고 검색 로그 표시를 선택합니다.

      검색 로그 창이 열립니다.
   2. 오른쪽 창에서 실패한 식별 섹션 및 이 섹션 내에서 실패한 단계를 찾습니다.
   3. 이 실패한 식별 섹션을 선택하고 디버그를 클릭합니다.

      디버그 식별 섹션 창이 열립니다.
   4. 필요한 경우 필요한 상세 정보를 입력하고 연결을 클릭합니다.
   {#troubleshoot-services-containing-SAP__ol_fvn_2pp_mfb}
2. 단계 아래의 변수 설정 단계를 클릭합니다.
3. 정규 표현식에 `SYS`가 포함되어 있는지 확인합니다.
4. 단계 아래에서 install_dir 설정 단계를 클릭합니다.
5. 정규 표현식에 `sap`가 포함되어 있는지 확인합니다.
{#troubleshoot-services-containing-SAP__ol_ffb_trf_2fb}

### 증상 {#troubleshoot-services-containing-SAP__section_zny_b5f_2fb}

서비스 매핑 에서 조직에서 SAP 디지털 비즈니스 서비스를 배포하는 데 사용하는 웹 서비스를 검색하지 못합니다.

### 원인 1 {#troubleshoot-services-containing-SAP__section_fjk_c5f_2fb}

웹 서비스를 식별하는 EVAL 함수에서 패턴 오류가 발생합니다.

### 솔루션 1 {#troubleshoot-services-containing-SAP__section_tpp_c5f_2fb}

1. 엔트리포인트의 형식이 매핑 절차에서 설명한 대로 웹 서비스의 URL인지 확인합니다.
2. 매핑 절차에서 설명한 대로 필요한 애플리케이션 자격 증명을 구성했는지 확인합니다.
3. 검색 로그에 다음 메시지가 포함되어 있는지 확인합니다. GROOVE_CODE_FAILURE: 속성이 없습니다. com for class: Script1.
4. 디버그 모드에서 실패한 패턴 단계를 다음과 같이 엽니다.
   1. 비즈니스 서비스 또는 서비스 인스턴스 맵에서 오류 메시지를 마우스 오른쪽 버튼으로 클릭하고 검색 로그 표시를 선택합니다.

      검색 로그 창이 열립니다.
   2. 오른쪽 창에서 실패한 식별 섹션 및 이 섹션 내에서 실패한 단계를 찾습니다.
   3. 이 실패한 식별 섹션을 선택하고 디버그를 클릭합니다.

      디버그 식별 섹션 창이 열립니다.
   4. 필요한 경우 필요한 상세 정보를 입력하고 연결을 클릭합니다.
   {#troubleshoot-services-containing-SAP__ol_lpf_zpp_mfb}
5. 선택한 식별 섹션을 표시하는 패턴 디자이너가 열립니다.
6. 오른쪽에서 실패한 단계를 선택합니다.
7. EVAL에서 실행되는 함수가 `com.snc.sw.util.HttpInvokerUtil.post` 인지 확인합니다.
8. 애플리케이션 서비스를 다시 매핑한 후 결과를 확인하십시오.
{#troubleshoot-services-containing-SAP__ol_j5q_2xf_2fb}

### 원인 2 {#troubleshoot-services-containing-SAP__section_bers_sbg_2fb}

웹 서비스가 잘못 구성되어 웹 서비스를 식별하는 EVAL 함수에서 패턴 오류가 발생합니다.

### 솔루션 2 {#troubleshoot-services-containing-SAP__section_cc5e_sbg_2fb}

1. 엔트리포인트의 형식이 매핑 절차에서 설명한 대로 웹 서비스의 URL인지 확인합니다.
2. 매핑 절차에서 설명한 대로 필요한 애플리케이션 자격 증명을 구성했는지 확인합니다.
3. 검색 로그에 다음 메시지가 포함되어 있는지 확인하십시오. "디버그 실행 레일: 테스트 단계가 실패했습니다. GROOVE_CODE_FAILURE: 호스트 10.x.x.x.에서 모든 명령 구현(HTTP)에 실패했습니다. 호스트가 다운되거나 연결할 수 없는 상태입니다. ()"
4. 설명된 대로 웹 서비스를 다시 만듭니다.<https://blogs.sap.com/2012/10/24/how-to-create-web-services-abap-based/>
5. 애플리케이션 서비스를 다시 매핑한 후 결과를 확인하십시오.
{#troubleshoot-services-containing-SAP__ol_dcd_sbg_2fb}

### 원인 3 {#troubleshoot-services-containing-SAP__section_px5_p84s_2fb}

엔트리포인트에 구성된 URL이 올바르지 않거나 이 URL에 액세스할 수 없기 때문에 MID 서버 웹 서비스를 식별하기 위한 EVAL 함수에서 패턴 오류가 발생합니다.

### 솔루션 3 {#troubleshoot-services-containing-SAP__section_q455_48g_2fb}

1. 엔트리포인트의 형식이 매핑 절차에서 설명한 대로 웹 서비스의 URL인지 확인합니다.
2. 매핑 절차에서 설명한 대로 필요한 애플리케이션 자격 증명을 구성했는지 확인합니다.
3. 검색 로그에 다음 메시지가 포함되어 있는지 확인하십시오. "디버그 실행 레일: 테스트 단계가 실패했습니다. GROOVE_CODE_FAILURE: 호스트 10.x.x.x.에서 모든 명령 구현(HTTP)에 실패했습니다. 호스트가 다운되거나 연결할 수 없는 상태입니다. ()"
4. 서비스 엔트리포인트에 대해 올바른 URL을 사용했는지 확인합니다.
   1. TCode SOAMANAGER에서 단순화된 웹 서비스 구성으로 이동합니다.
   2. 단순화된 서비스 구성 창의 구성 탭에서 에 서비스 인스턴스속하는 웹 서비스를 검색합니다.
   3. 이 웹 서비스의 사용자 이름/암호(기본) 아래의 확인란을 클릭합니다.
   4. 상세 정보 표시를 클릭합니다.
   5. 서비스 정의 창의 상세 정보에서 WSDL URL 아래에 있는 웹 서비스의 실제 URL을 확인합니다.
   6. 필요한 경우 엔트리포인트에 대해 구성하는 URL을 수정하고 다시 매핑 서비스 인스턴스 해 보십시오.
   {#troubleshoot-services-containing-SAP__ol_z4c_thg_2fb}
{#troubleshoot-services-containing-SAP__ol_rx5_pdg_2fb}

### 원인 4 {#troubleshoot-services-containing-SAP__section_kwfrm_z3g_2fb}

MID 서버 의 엔트리포인트 서비스 인스턴스에서 구성한 이 URL에 액세스할 수 없습니다.

### 솔루션 4 {#troubleshoot-services-containing-SAP__section_l4ersm_z3g_2fb}

1. 엔트리포인트의 형식이 매핑 절차에서 설명한 대로 웹 서비스의 URL인지 확인합니다.
2. 매핑 절차에서 설명한 대로 필요한 애플리케이션 자격 증명을 구성했는지 확인합니다.
3. 검색 로그에 다음 메시지가 포함되어 있는지 확인하십시오. "디버그 실행 실패: 테스트 단계가 실패했습니다. GROOVE_CODE_FAILURE: 호스트 10.x.x.x.에서 모든 명령 구현(HTTP)에 실패했습니다. 호스트가 다운되거나 연결할 수 없는 상태입니다. ()"
4. 서비스 엔트리포인트에서 구성한 URL에 액세스할 수 있는 을 사용했는지 확인합니다.MID 서버
   1. 호스트에 원격으로 로그인합니다 MID 서버 .
   2. 브라우저를 엽니다.
   3. URL을 브라우저 주소 표시줄에 붙여넣고 Enter 키를 누릅니다.
   4. 페이지가 열리지 않으면 네트워크 문제가 있음을 의미합니다. 예를 들어 이 URL에 액세스하지 못하도록 하는 MID 서버 방화벽이 있는 경우와 같습니다.
   {#troubleshoot-services-containing-SAP__ol_n4m_z3g_2fb}{#troubleshoot-services-containing-SAP__VerifyingCredentials-networkIssues}
{#troubleshoot-services-containing-SAP__VerifyingCredentials-networkIssues}
5. 네트워크 문제를 해결하고 단계에서 설명한 대로 URL에 액세스할 수 있는지 확인합니다MID 서버.[4](https://servicenow-prod.fluidtopics.net/WuZL63zvfiUx1ZZTg8oY4Q#troubleshoot-services-containing-SAP__VerifyingCredentials-networkIssues)
{#troubleshoot-services-containing-SAP__ol_m4m_z3g_2fb}

### 원인 5 {#troubleshoot-services-containing-SAP__section_qjm_ewg_2fb}

MID 서버 의 엔트리포인트 서비스 인스턴스에서 구성한 이 URL에 액세스할 수 없습니다.

### 해결 방법 5 {#troubleshoot-services-containing-SAP__section_r99_3mg_2fb}

1. 엔트리포인트의 형식이 매핑 절차에서 설명한 대로 웹 서비스의 URL인지 확인합니다.
2. 매핑 절차에서 설명한 대로 필요한 애플리케이션 자격 증명을 구성했는지 확인합니다.
3. 검색 로그에 다음 메시지가 포함되어 있는지 확인하십시오. "디버그 실행 레일: 테스트 단계가 실패했습니다. GROOVE_CODE_FAILURE: 호스트 10.x.x.x.에서 모든 명령 구현(HTTP)에 실패했습니다. 호스트가 다운되거나 연결할 수 없는 상태입니다. ()"
4. 웹 서비스에 대해 구성 ServiceNow AI Platform 한 애플리케이션 자격 증명이 유효한지 확인합니다.
   1. 호스트에 원격으로 로그인합니다 MID 서버 .
   2. 브라우저를 엽니다.
   3. URL을 브라우저 주소 표시줄에 붙여넣고 Enter 키를 누릅니다.
   4. 브라우저 페이지에 자격 증명 팝업 창이 표시됩니다.
   5. 자격 증명을 입력하고 페이지가 열리는지 확인합니다. 페이지가 열리지 않으며 구성한 애플리케이션 자격 증명이 잘못되었음을 의미합니다.

   {#troubleshoot-services-containing-SAP__ol_tjm_3mg_2fb}{#troubleshoot-services-containing-SAP__CredetialVerif-IncorrectCredtials}
{#troubleshoot-services-containing-SAP__CredetialVerif-IncorrectCredtials}
5. 올바른 자격 증명을 찾습니다.
6. 단계에 설명된 대로 새 자격 증명을 확인합니다.[4](https://servicenow-prod.fluidtopics.net/WuZL63zvfiUx1ZZTg8oY4Q#troubleshoot-services-containing-SAP__CredetialVerif-IncorrectCredtials)
7. 새 자격 증명을 사용한 후 페이지가 열리면 이러한 자격 증명을 애플리케이션 자격 증명 ServiceNow AI Platform으로 구성합니다.
{#troubleshoot-services-containing-SAP__ol_sjm_3mg_2fb}

### 원인 6 {#troubleshoot-services-containing-SAP__section_skg_wmg_2fb}

MID 서버 의 엔트리포인트 서비스 인스턴스에서 구성한 이 URL에 액세스할 수 없습니다.

### 해결 방법 6 {#troubleshoot-services-containing-SAP__section_tkg_wmg_2fb}

1. 엔트리포인트의 형식이 매핑 절차에서 설명한 대로 웹 서비스의 URL인지 확인합니다.
2. 검색 로그에 다음 메시지가 포함되어 있는지 확인하십시오. "디버그 실행 레일: 테스트 단계가 실패했습니다. GROOVE_CODE_FAILURE: CI 유형 \<CI 유형의 이름\>"에 대한 적용성 자격 증명이 없습니다.
3. 설명된 대로 [애플리케이션을 포함하는 SAP 애플리케이션 서비스 매핑](https://servicenow-prod.fluidtopics.net/WuZL63zvfiUx1ZZTg8oY4Q#map-service-containing-SAP "애플리케이션을 포함하는 서비스 인스턴스를 SAP 매핑하고 모든 SAP 구성요소가 올바르게 검색되었는지 확인합니다서비스 매핑.")관련 CI에 대한 애플리케이션 자격 증명을 정의했는지 확인합니다.
{#troubleshoot-services-containing-SAP__ol_ukg_wmg_2fb}

