---
sourceDocument: Yokohama データと自動化
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/ja-JP/yokohama/integrate-applications

 Release :

    - yokohama

ft:locale :

    - ja-JP

ft:publication_title :

    - Yokohama データと自動化

ft:clusterId :

    - crint

bundleId :

    - crint

workflow :

    - Creator


---

# PowerShell のトラブルシューティング

# PowerShell のトラブルシューティング {#ariaid-title1}

* リリースバージョン: Yokohama
* 
* 更新日 2025年01月30日
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 所要時間：4分

認証とアクセス拒否のエラーにより、PowerShell アクティビティがターゲット ホストでコマンドを実行できなくなる可能性があります。  
オーケストレーション PowerShell アクティビティによる認証エラー、リモート プロシージャ コール (RPC) サーバーが使用できない場合、またはアクセスが拒否された場合のトラブルシューティングに次の手順を使用します。ローカル MID サーバーサービス アカウントの認証情報を含む、すべての認証情報に Powershell スクリプト/コマンドの実行に適したアクセス権限がない場合、認証失敗エラーが表示されます。ターゲット ホストに到達できない場合、同じエラーが表示されます。 図 : 1. 認証エラーメッセージ

## Active Directory アクティビティの認証エラー {#ariaid-title2}

次の例では、\[AD オブジェクトを作成\] アクティビティを使用して、PowerShell の認証エラーのトラブルシューティングを説明します。

### 始める前に

必須ロール：Active Directory のアカウントにアクセスおよび作成する権限

### このタスクについて

使用しているアカウントにアクティビティの実行に適した権限があることを確認します。

### 手順

1. アクティビティを実行するアカウントを使用してターゲット マシンにログオンします。  
   このマシンに Active Directory ツールをインストールする必要があります。
2. Active Directory のユーザーとコンピュータのアプリケーションを起動します。
3. Active Directory オブジェクトを作成する OU に移動します。
4. オブジェクトの作成を試みます。  
   指定したユーザーでこの手順が成功した場合、認証失敗の原因は次のとおりです。
   * ユーザー名が無効です。
   * 入力したパスワードが間違っています。
   * ドメインコントローラーに到達できません。

   {#troubleshoot-ad-auth-failure__ul_yvw_zlr_dw}  
   注:  
   このエラーの MID サーバーログにリストされているリターン コードの大部分は 1 および 3 です。これは、Active Directory アクティビティが WMI または WinRM ではなく ADSI プロバイダーを使用するためです。エラー コード 1 は、アカウントはテスト アカウントにコネクトしたけれども、スクリプトの実行に失敗したことを意味します。  
   エラー コード 3 は、MID サーバーが MID サーバーサービス アカウントで PowerShell アクティビティを実行しようとしたけれども、失敗したことを意味します。

## Exchange アクティビティの認証失敗 {#ariaid-title3}

次の例では、\[メールボックスの作成\] アクティビティを使用して、PowerShell の認証エラーのトラブルシューティングを説明します。

### 始める前に

必須ロール：Exchange サーバー上のメールボックスにアクセスおよび作成する権限

### 手順

1. 使用しているアカウントに PowerShell アクティビティの実行に適した権限があることを確認します。
2. Exchange 管理シェル (EMS) がインストールされているマシンにログオンします。
3. `New-mailbox` Exchange コマンドレットを使用してユーザーを作成します。  
   図 : 2. Exchange で新しいユーザーを作成する  
   指定した認証情報でこの手順が成功した場合、失敗の原因は次の可能性があります。
   * ユーザー名が無効です。
   * 入力したパスワードが間違っています。
   * Exchange サーバーに到達できません。
   {#troubleshoot-exchange-auth-failure__ul_yvw_zlr_dw}
4. Exchange サーバーに到達できない場合は、MID サーバーログを調べます。  
   Exchange アクティビティは WinRM を使用して Exchange サーバーにアクセスするため、ログにはトラブルシューティングの詳細情報が表示されます。  
   注:  
   このエラーは「WinRM が要求を処理できない」ことを示しているわけではないことを確認します。

## リモート プロシージャ コール (RPC) サーバーが使用不可、またはアクセスが拒否される {#ariaid-title4}

通常、WinRM または WMI を使用する PowerShell スクリプト/コマンドを実行すると、このエラーが記録されます。

### 考えられるエラーの原因

ターゲット ホストには、次のいずれかの問題があります。

* WinRM が設定されていません。
* ファイアウォールは、TCP ポート 135 (WMI) または HTTP/HTTPS と TCP ポート5985 (WinRM) を介したホストへのアクセスをブロックします。
* WMI を使用して複数のホストにホッピングすることで発生する Kerberos の問題。
{#rpc-server-unavail-access-denied__ul_f1z_ptr_dw}

### WinRM エラーの例

Exchange アクティビティパックの \[メールボックスの作成\] アクティビティで、MID サーバーサービスの認証情報を使用した認証に関連する ECC キューにエラーが発生しました。これは、ターゲット ホストが MID サーバーでない場合、MID サーバーの認証情報が最後に使用されるために発生しました。図 : 3. 認証失敗エラーメッセージ  
MID サーバーログは、MID サーバーが特定の認証情報でアクティビティを実行しようとしたけれども成功せず、終了コード 1 を受信したことを示しています。図 : 4. MID サーバーのエラー コード

