---
sourceDocument: オーストラリア ServiceNow AI Platform の機能
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/ja-JP/servicenow-platform

 Release :

    - australia

ft:locale :

    - ja-JP

ft:publication_title :

    - オーストラリア ServiceNow AI Platform の機能

ft:clusterId :

    - platcap

bundleId :

    - platcap

workflow :

    - Platform


---

# MID サーバープロパティ

# MID サーバープロパティ {#ariaid-title1}

* リリースバージョン: Australia
* 
* 更新日 2026年03月12日
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 所要時間：27分

すべての MID サーバーまたは特定の MID サーバーの動作をプロパティが制御します。

|-|
|   |
[ ]

{#r_MIDServerProperties__table_gwj_2sf_khb} MID サーバープロパティは MID サーバープロパティ \[ecc_agent_property\] テーブルにあり、次の場所に移動することでアクセスできます MID サーバープロパティ. 次のプロパティが存在しない場合、これらを設定するには、これらを追加する必要があります。

## MID サーバープロパティ {#r_MIDServerProperties__section_e1y_zky_sfb}

com.glide.closure_max_rows_per_table
:   テーブルで許容される行の最大数を設定します。このプロパティはデフォルトでは表示されず、追加する必要があります。

    * タイプ：整数
    * デフォルト値：200000
    {#r_MIDServerProperties__ul_xwz_mym_mfb}

concurrent.dist.download
:   インスタンスによって許可される、同時に実行される MID サーバーの自動アップグレードの数を設定します。このプロパティのデフォルト値は 2 です。これにより、MID サーバーはインスタンスで利用可能な 4 つのセマフォのうち 2 つをアップグレードに使用できます。インスタンスに 4 つ以上の INT セマフォがある場合は、このプロパティの値を増やしてより多くの同時アップグレードを許可することができます。

    * タイプ：整数
    * デフォルト値：2
    {#r_MIDServerProperties__ul_wsw_tfh_nhb}

glide.stored_proc.data_type.validation
:   ストアド プロシージャのパラメーターのデータタイプの検証を停止します。オーケストレーションを使用して MySQL、Oracle DB、および MS-SQL データベースでのストアド プロシージャを実行し、データタイプの検証を行わない場合は、このプロパティを使用します。このプロパティの値を変更した後は、MID サーバーサービスを再起動します。

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_psj_jjz_r1b}

mid.discovery.max_ci_count_per_page
:   ページあたりの最大 CI 数を定義します。

    * タイプ：整数 (バイト)
    * デフォルト値： 500

    {#r_MIDServerProperties__ul_plz_skz_cmb}

    [個々の MID サーバーの設定パラメーター](https://servicenow-prod.fluidtopics.net/jmOmC2sAJkDa~pYBu9~Blw#t_SetMIDServerParameters "特定の MID サーバーの動作をコントロールするには、MID サーバーパラメーターを使用します。")として設定することもできます。

mid.discovery.max_related_count_per_page
:
    * タイプ：整数
    * デフォルト：100
    {#r_MIDServerProperties__ul_ll4_kh1_lbc}

mid.discovery.max_relation_count_per_page
:   その中の関係の数に基づいてペイロードを分割します。

    * タイプ：整数
    * デフォルト：10000
    {#r_MIDServerProperties__ul_yhg_1rp_cfc}

mid.discovery.max_total_items_size_per_page
:   アイテムのサイズに基づいてペイロードを分割します。

    * タイプ：整数
    * Default (デフォルト)：
    {#r_MIDServerProperties__ul_egz_kh1_lbc}

mid.aws.sts.assume_role.disable_credential_caching
:   クラウドディスカバリー の一時的な認証情報のキャッシュを防止するには、このプロパティを true に設定します。詳細については、「[AWS サービスアカウントのアクセスセットアップ](https://www.servicenow.com/docs/access?context=access-aws-accounts&version=australia&pubname=australia-it-operations-management&ft:locale=en-US)」を参照してください [のアクセスセットアップ AWS サービスアカウント](https://www.servicenow.com/docs/access?context=access-aws-accounts&version=australia&pubname=australia-it-operations-management&ft:locale=en-US).

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_lbk_fkz_cfb}

mid.aws.sts.assume_role.credential_ttl_minutes
:   クラウドディスカバリー の一時的な認証情報をキャッシュする期間を分単位で設定します。詳細については、「[AWS サービスアカウントのアクセスセットアップ](https://www.servicenow.com/docs/access?context=access-aws-accounts&version=australia&pubname=australia-it-operations-management&ft:locale=en-US)」を参照してください [のアクセスセットアップ AWS サービスアカウント](https://www.servicenow.com/docs/access?context=access-aws-accounts&version=australia&pubname=australia-it-operations-management&ft:locale=en-US).

    * タイプ：整数
    * デフォルト：60
    {#r_MIDServerProperties__ul_xym_3kz_cfb}

mid.ca.certificate.api.request.retry.count
:   レート制限が発生した後に証明書のインポートクエリを再試行する回数を示します。

    * タイプ：整数
    * デフォルト値：3
    {#r_MIDServerProperties__ul_opd_fqn_3kb}

mid.ca.certificate.api.request.retry.interval
:   レート制限が発生したときに CA からの証明書のインポートを遅らせるために使用されます。

    * タイプ：整数
    * デフォルト：30000
    {#r_MIDServerProperties__ul_llb_1qn_3kb}

mid.cloud.discovery.bypass.proxy

:   この設定パラメーターは、プロキシサーバーの DNS/IP アドレスのカンマ区切りリストを受け入れます。リストされたプロキシサーバーは、クラウドディスカバリー中にバイパスされます。複数のクラウドサービスプロバイダー (AWS や Azure など) でプロキシをバイパスするには、プロバイダーごとに個別の MID サーバーを設定する必要があります。そうしない場合、通常どおり MID サーバーのプロキシ設定に従います。

    * タイプ：文字列
    * デフォルト値：なし
    {#r_MIDServerProperties__ul_kjd_jv5_gxb}

mid.discovery.file_transfer_protocol
:   プローブまたはパターンに使用するファイル転送方法を決定するために使用されます。

    * タイプ：選択肢 (SCP または SFTP)
    * デフォルト：SCP
    {#r_MIDServerProperties__ul_wll_nnl_ntb}

mid.discovery.max_pattern_payload_size
:   パターンから得られた結果のペイロードの総合最大ペイロード サイズを定義します。

    * タイプ：整数 (バイト)
    * デフォルト値：50000000

    {#r_MIDServerProperties__ul_ofs_qbr_t1b}

    [個々の MID サーバーの設定パラメーター](https://servicenow-prod.fluidtopics.net/jmOmC2sAJkDa~pYBu9~Blw#t_SetMIDServerParameters "特定の MID サーバーの動作をコントロールするには、MID サーバーパラメーターを使用します。")として設定することもできます。

mid.discovery.max_payload_size
:   MID サーバーがインスタンスに送信するディスカバリー結果の最大文字列長を指定します。ディスカバリープローブの結果が制限を超えると、MID サーバーはそれらを破棄して警告メッセージを返します。

    プローブの場合、これは \[ディスカバリーで使用\] フィールドが true のプローブにのみ適用されます。 パターンの場合、これは[水平パターンプローブ](https://www.servicenow.com/docs/access?context=r-HorizontalPatternProbe&version=australia&pubname=australia-it-operations-management&ft:locale=en-US)に適用されます。

    ペイロード制限を無効にして、任意のサイズのペイロードをインスタンスに送信できるようにするには、値を任意の負の数に設定します。たとえば、-1 にします。

    * タイプ：整数 (バイト)
    * デフォルト値：5000000

    {#r_MIDServerProperties__ul_hyv_1jv_tp}

    [個々の MID サーバーの設定パラメーター](https://servicenow-prod.fluidtopics.net/jmOmC2sAJkDa~pYBu9~Blw#t_SetMIDServerParameters "特定の MID サーバーの動作をコントロールするには、MID サーバーパラメーターを使用します。")として設定することもできます。

mid.discovery.multiprobe.skip_others_on_error
:   別のメンバープローブがすでに失敗またはタイムアウトしたときに、[マルチプローブ](https://www.servicenow.com/docs/access?context=r_MultiprobesIncludedWithDiscovery&version=australia&pubname=australia-it-operations-management&ft:locale=en-US)内のプローブが利用可能な認証情報を反復処理しないようにします。このプロパティが false に設定されている場合、マルチプローブ内の各プローブは、同じ無効な認証情報を使用してターゲットへの接続を試行します。この条件では、MID サーバーでのプローブの実行時間が長くなります。

    このプロパティはデフォルトでは表示されず、sys_properties テーブルに追加して値を変更する必要があります。

    * タイプ：true \| false
    * デフォルト値：true
    {#r_MIDServerProperties__ul_i4z_bn5_d3b}

mid.discovery.aws_ssm.kms_key_name

:   専用キーを使用すると、適用可能な認証情報が暗号化され、実行時にプレーン テキストで公開されることなく安全に取得されることを検証することで、セキュリティが強化されます。この手順はオプションであり、ディスカバリー中に適用可能な認証情報を使用する場合にのみ必要です。SSM エージェントの検出中に安全な認証情報処理をサポートするように MID サーバーを構成するには、 mid.discovery.aws_ssm.kms_key_name プロパティを AWS KMS キーの名前に設定します。

    * タイプ: 文字列
    * デフォルト値：なし
    {#r_MIDServerProperties__ul_ukk_wqg_cgc}

mid.discovery.aws_ssm.kms_key_region

:   専用キーを使用すると、適用可能な認証情報が暗号化され、実行時にプレーン テキストで公開されることなく安全に取得されることを検証することで、セキュリティが強化されます。この手順はオプションであり、ディスカバリー中に適用可能な認証情報を使用する場合にのみ必要です。SSM エージェントの検出中に安全な認証情報処理をサポートするように MID サーバーを構成するには、 mid.discovery.aws_ssm.kms_key_region プロパティをキーが配置されているリージョンに設定します。

    * タイプ: 文字列
    * デフォルト値：なし
    {#r_MIDServerProperties__ul_qs3_frg_cgc}

mid.discovery.aws_ssm.s3_bucket_name

:   SSM Run Command コンソールには 24,000 文字の制限があるため、この制限を超える結果は S3 バケットに保存し、S3 バケットから取得する必要があります。\[ファイルを配置\] コマンドの場合、S3 バケットは MID サーバーと AWS 環境間の転送ポイントとしても機能し、SSM 経由でターゲットデバイスにファイルを配信できます。これらの S3 ベースの操作をサポートするように MID サーバーを構成するには、 mid.discovery.aws_ssm.s3_bucket_name プロパティを SSM エージェントの検出に使用される S3 バケットの名前に設定します。

    * タイプ: 文字列
    * デフォルト値：なし
    {#r_MIDServerProperties__ul_aty_3rg_cgc}

mid.discovery.aws_ssm.s3_bucket_region

:   SSM Run Command コンソールには 24,000 文字の制限があるため、この制限を超える結果は S3 バケットに保存し、S3 バケットから取得する必要があります。\[ファイルを配置\] コマンドの場合、S3 バケットは MID サーバーと AWS 環境間の転送ポイントとしても機能し、SSM 経由でターゲットデバイスにファイルを配信できます。これらの S3 ベースの操作をサポートするように MID サーバーを構成するには、バケットのリージョンを mid.discovery.aws_ssm.s3_bucket_region プロパティで設定します。

    * タイプ: 文字列
    * デフォルト値：なし
    {#r_MIDServerProperties__ul_kzm_lrg_cgc}

mid.discovery.aws_ssm.linux.fallback_root_user

:   glide.discovery.enable_ssmプロパティが有効になっている場合、Linux 上の AWS SSM ディスカバリーはデフォルトでコマンド実行にルートユーザーを使用します。EC2 インスタンスで代替ユーザー認証情報を構成しない場合は、 mid.discovery.aws_ssm.linux.fallback_root_user プロパティを有効にして、root 実行へのフォールバックを許可する必要があります。有効にすると、ユーザー名が root のレコードが AWS SSM インスタンスユーザー \[aws_ssm_instance_user_credentials\] テーブルに自動的に作成されます。ただし、このプロパティを false のままにする場合は、ディスカバリーコマンドを実行するためにルート以外の認証情報を構成する必要があります。

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_ahz_4rg_cgc}

mid.eccq.max_payload_size
:   MID サーバーがインスタンスに送信するペイロードの最大文字列長を指定します。MID サーバーがインスタンスに送信する前にペイロードのサイズを確認します。ペイロードのサイズが制限を超えた場合、MID サーバーはそれを破棄し、ペイロードにエラーメッセージを返します。

    * タイプ：整数 (バイト)
    * デフォルト値：20000000

    {#r_MIDServerProperties__ul_mgd_jjv_tp}

    [個々の MID サーバーの設定パラメーター](https://servicenow-prod.fluidtopics.net/jmOmC2sAJkDa~pYBu9~Blw#t_SetMIDServerParameters "特定の MID サーバーの動作をコントロールするには、MID サーバーパラメーターを使用します。")として設定することもできます。

mid.http_classy.allow_credentials_over_http
:   ディスカバリー中に HTTP プロトコルを介して認証情報を送信するための HTTP 分類プローブを有効にします。

    * タイプ：true \| false
    * デフォルト値：false

    {#r_MIDServerProperties__ul_w4k_ndw_zfc}  
    警告:  
    この設定を有効にすると、認証情報が中間者 (MitM) 攻撃などのセキュリティリスクにさらされる可能性があります。したがって、このプロパティを false に設定したままにし、可能な限り HTTPS を使用することを強くお勧めします。

mid.install_server.base_uri

:   このシステムプロパティを変更するには、メンテナンス権限が必要です。MID サーバーでは、更新ファイルを要求するときにベース URL として指定された値を使用します。

    * タイプ：文字列
    * デフォルト値：https://install.service-now.com
    {#r_MIDServerProperties__ul_a43_v3h_35b}

mid.jdbc.datastream.max.record.size
:   最大レコードサイズを KB 単位で指定します。

    * タイプ：整数
    * デフォルト値：64
    * 最大値：128
    {#r_MIDServerProperties__ul_nm5_cqk_h4b}

mid.jdbc.datastream.fail.when.attachement.limit.exceeded
:   最大 4 GB のデータ (添付ファイルが 4 つ、それぞれのサイズが 1 GB) を RDBMS から取得できるかどうかを指定します。デフォルトでは、取得するデータが 4 GB を超える場合、フローまたはアクションはエラーで失敗します。サイズが 4 GB のデータをエラーなしで取得するには、値を <kbd class="ph userinput">false</kbd> に設定します。

    * タイプ：文字列
    * デフォルト：true
    {#r_MIDServerProperties__ul_m2t_drk_h4b}

mid.keystore.max_backups
:   手動のキーストア操作によるバックアップの最大数を、 manage_certificate スクリプトで指定します。0 または負の値の場合、バックアップは作成されません。

    * タイプ：整数
    * デフォルト値：3
    {#r_MIDServerProperties__ul_jjf_s2n_25b}

mid.keystore.max_live_backups
:   実行中の MID サーバーからのライブバックアップの最大数を指定します。0 または負の値の場合、バックアップは作成されません。

    * タイプ：整数
    * デフォルト値：2
    {#r_MIDServerProperties__ul_kwn_v2n_25b}

mid.keystore.backup_overwrite_timespan
:   バックアップの数が最大数を超えた場合に、新しいバックアップを作成して最も古いバックアップを削除するのではなく、最新のバックアップを新しいバックアップに置き換えるかどうかを決定するために、現在のバックアップ時刻からの秒数を指定します。

    * タイプ：整数
    * デフォルト値： 60
    {#r_MIDServerProperties__ul_y21_y2n_25b}

mid.log.command_audit.enable
:   MID サーバーコマンド監査ログを有効にします。

    * タイプ：文字列
    * デフォルト値：false
    {#r_MIDServerProperties__ul_ivn_224_wnb}

mid.powershell.target_base_dir
:   WMI を使用したディスカバリーに使用するターゲットベースフォルダーの場所を指定します。Windows の各ターゲットに別のネットワーク共有がマウントされている場合、このプロパティを更新することによって、フォルダーが変更される可能性があります。

    * タイプ：文字列
    * デフォルト値 ：admin $ \\ temp
    {#r_MIDServerProperties__ul_rvf_sm2_d3b}

mid.probe.collect_debug_info

:   デバッグ情報を収集するためのオプションのプロパティ。このプロパティが true に設定されている場合、プローブは実行時に認証情報のデバッグ情報を収集し、ECC 入力メッセージのペイロードに情報を格納します。ディスカバリーの仕組みには影響しません。

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_rpk_rvz_qjb}

mid.probe.use_legacy_forward_dns
:   従来の DNSNameResolver プローブを有効にし、デフォルトの DNSNameResolver プローブを無効にします。詳細については、「[Probes used by Orchestration](https://www.servicenow.com/docs/access?context=r_OrchestrationProbes&version=australia&pubname=australia-integrate-applications&ft:locale=en-US)」を参照してください。

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_ewm_qzm_phb}

mid.probe.use_legacy_reverse_dns
:   従来の DNS プローブを有効にし、デフォルトの DNS プローブを無効にします。デフォルトの DNS プローブの機能で問題が発生した場合は、このプロパティを使用してこれらの機能を無効にします。デフォルトの DNS プローブの機能には、並列で実行されるため軽量で高速な機能がありますが、従来のプローブはシリアルで実行されるため MID サーバーによって抑制されます。デフォルトのプローブは、MID サーバーホスト OS による DNS ルックアップを使用して、維持されている DNS キャッシュを利用します。従来のプローブとは異なります。そのため、Windows システムでデフォルトのプローブによる DNS ルックアップが失敗した後、OS は NETBIOS 名によるルックアップも試行します。

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_xgs_kwm_phb}

mid.process_flow.log_listener.max_size
:   ワークフロースタジオで実行されているMID サーバー アクションのログ メッセージを保存するために利用可能なメモリの最大サイズをバイト単位で設定します。MID サーバーはメモリに制限まで保存し、追加のログ メッセージを破棄してから、メッセージを実行計画とともにインスタンスに送り返します。

    * タイプ：整数 (バイト)
    * デフォルト値：10485760
    {#r_MIDServerProperties__ul_xjy_jq2_wdb}

mid.property.jdbc_operations
:   JDBCOrchestrationProbe に実行可能な JDBC 操作を通知します。JDBC オーケストレーション アクティビティでより多くの操作を実行できるようにするには、このプロパティ値を編集します。すべての操作がカンマで区切られています。\[MID サーバー\] フィールドで MID サーバーを選択してその MID サーバー用の特定の操作を定義するか、このフィールドを空のままにして操作のリストをすべての MID サーバーに適用します。このプロパティにはオーケストレーション プラグインが必要です。

    * タイプ：文字列
    * デフォルト値：select,update,insert,delete,show,create,describe,begin,if,end,not,exists
    {#r_MIDServerProperties__ul_yyb_gsd_pw}

mid.property.jms.command.allowed_factory_names
:   カスタム JMS アクティビティまたはアクションのために MID サーバーが必要とする Java Messaging Service (JMS) 接続ファクトリーのカンマ区切りリスト。このプロパティにはオーケストレーション プラグインが必要です。

    * タイプ：文字列
    * デフォルト値：connectionFactory, queueConnectionFactory, topicConnectionFactory
    {#r_MIDServerProperties__ul_jmg_gsd_pw}

mid.property.ssh.use_snc
:   Discovery とオーケストレーションが SNCSSH クライアントを使用できるようにします。J2SSH を使用するには、このプロパティを false に変更します。このプロパティは、インスタンスに接続されているすべての MID サーバーに適用されます。

    * タイプ：true \| false
    * デフォルト値：true
    {#r_MIDServerProperties__ul_xz1_prd_pw}

mid.property.powershell.use_base64_password
:   認証情報が特定の MID サーバーに固有のものとして設定されている場合は、このプロパティもその同じ MID サーバーに設定することができます。\[MID サーバー\] フィールドを空のままにすると、すべての MID サーバーに適用されます。

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_w1w_mkv_zyb}

mid sa. prefer_powershell
:   MID サーバーを有効にして PowerShell リモート機能を使用します。  
    注:  
    このプロパティは使用廃止になったため、変更することはお勧めしません。

    * タイプ：True \| False
    * デフォルト値：true
    {#r_MIDServerProperties__ul_z35_q1r_rfb}

mid.sa.ssh.use_sncssh
:   SSH を非インタラクティブモードとインタラクティブモードの間で切り替えます。True の場合は、非インタラクティブモードになり、プローブはプロンプトを待機することなく、デバイスとのセッションを開くことができます。False の場合は、インタラクティブモードになるため、ネットワークデバイスとサーバーのデバイスとのインタラクティブセッションが必要です。

    * タイプ：True \| False
    * デフォルト値：true
    {#r_MIDServerProperties__ul_ucp_zl4_kmb}

mid.sa.windows.allowable_failures

:   MID サーバー がパターンの実行を停止するまでに許容される失敗の数を指定します。制限に達すると、次の失敗でパターンは終了します。認証の失敗、コマンドタイムアウト、コマンド実行の例外などの問題により、PowerShell コマンドを正常に完了できない場合にエラーが発生します。

    * タイプ：整数
    * デフォルト値：2
    * 値：
      * 0:最初の失敗はパターンを直ちに終了します。
      * 1: 最初の失敗は許容されます。2 番目の失敗はパターンを終了します。
      * 2:2つの失敗は許容されます。3 回目の失敗はパターンを終了します。
      * -1:失敗の上限はありません。このパターンは、失敗の数に関係なく続行されます。
      {#r_MIDServerProperties__ul_k5s_3qw_2hc}
    {#r_MIDServerProperties__ul_fg2_cxs_hgc}

mid.servicewatch.max_concurrent_connections
:   単一の MID サーバーにより個別ホストに送信される同時タスクの最大数を定義します。

    * タイプ：整数
    * デフォルト値：7
    {#r_MIDServerProperties__ul_fbs_bkg_gy}

mid.shazzam.regulator.interval_ms
:   Shazzam がパケットを開始できる間隔をミリ秒単位で設定します。

    * タイプ：整数
    * デフォルト値： 1
    {#r_MIDServerProperties__ul_tpp_nq2_d3b}

mid.shazzam.regulator.packets_per_interval
:   Shazzam が mid.shazzam.regulator.interval_ms プロパティによって指定される時間間隔で起動できるパケットの数を設定します。

    * タイプ：整数
    * デフォルト値： 1
    {#r_MIDServerProperties__ul_ngp_pq2_d3b}

mid.shazzam.threads
:   Shazzam が使用する同時スレッド数を指定します。これまたは mid.shazzam.max_scanners_per_thread パラメーターを 0 に設定すると、Shazzam マルチスレッド最適化が無効になります。

    * タイプ：整数
    * デフォルト値： 5
    {#r_MIDServerProperties__ul_nxl_1sb_x3b}

mid.shazzam.max_scanners_per_thread
:   各 Shazzam スレッドによって処理される同時スキャナーの数を指定します。これまたは mid.shazzam.threads パラメーターを 0 に設定すると、Shazzam の最適化が無効になります。

    * タイプ：整数
    * デフォルト値： 100
    {#r_MIDServerProperties__ul_zl1_4sb_x3b}

mid.sm.discolog.max_log_size
:   水平ディスカバリーログのログステートメントの長さを制限します。結果が切り捨てられた場合、 コマンドの結果 は、「結果が \[値\] 文字より長いため、ロガーによって切り捨てられました (Result is larger than \[value\] characters and was truncated by the logger)」と表示されます。

    * タイプ：整数（文字）
    * デフォルト値：1000
    {#r_MIDServerProperties__ul_ovf_jt1_lhb}

mid.sm.discolog.max_object_size
:   水平ディスカバリーログのオブジェクトの長さを制限します。ログステートメント内のオブジェクトは、このプロパティの値で設定された文字数に切り捨てられます。このプロパティは、水平ディスカバリーログのオブジェクトの文字サイズにのみ影響します。オブジェクトがこのプロパティによって制限されている場合、次のメッセージが表示されます。「オブジェクトの最大サイズが \[値\] の上限に達しました。これを調整するには、mid プロパティ mid.sm.discolog.max_object_size を使用します。(The max object size reached the maximum limit of \[value\]. To adjust this use the mid property mid.sm.discolog.max_object_size.)」

    * タイプ：整数（文字）
    * デフォルト値：5000
    {#r_MIDServerProperties__ul_fsd_yt1_lhb}

mid.snmp.use_getbulk
:   大量のデータを一括で受信するために GETBULK を使用するかどうかを指定します。これは、すべての MID サーバーをグローバルに構成するために使用できます。

    * タイプ：true \| false
    * デフォルト値：true

    {#r_MIDServerProperties__ul_brm_ln3_chb}  
    GETBULK は、プローブレベルまたは個々の MID サーバーに対して設定することもできます。設定は、優先度の順にリストされます。

    * [SNMP プローブパラメーター](https://www.servicenow.com/docs/access?context=r_SNMPProbeParameters&version=australia&pubname=australia-it-operations-management&ft:locale=en-US)
    * [MID サーバー構成パラメータ―](https://servicenow-prod.fluidtopics.net/jmOmC2sAJkDa~pYBu9~Blw#mid-server-parameters "パラメーターは特定の MID サーバーの動作を制御し、MID サーバープロパティよりも優先順位が低いです。")
    * MID サーバープロパティ
    {#r_MIDServerProperties__ul_wy2_2n5_dhb}

mid.ssh.algorithms.kex
:   鍵交換 SSH アルゴリズムの優先度リストを変更します。プロパティは、カンマ区切りの演算子付きリストを受け取ることができます。リストの名は最も優先度が高く、リストの姓は最も優先度が低くなります。演算子を使用せずにカンマ区切りのリストを追加すると、デフォルトのアルゴリズムリストが置き換えられます。詳細については、「[MID Server SSH 暗号化アルゴリズム](https://servicenow-prod.fluidtopics.net/GNKPfsBu_07rkfmR4NiAYw "MID サーバーは SSH クライアントを利用して多くのディスカバリーアクションを実行します。SSH ハンドシェイクでは、クライアントとサーバーの両方が、最初に双方がサポートするアルゴリズムを決定し、次にクライアントが最も優先度の高いアルゴリズムを選択します。ホストキーアルゴリズムの場合、クライアントは、キータイプに一致する、双方がサポートする最も優先度の高いアルゴリズムを選択します。")」を参照してください。

    * タイプ：文字列
    * デフォルト値：ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha256,diffie-hellman-group16-sha512,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1,diffie-hellman-group-exchange-sha1
    {#r_MIDServerProperties__ul_sgg_lms_xnb}

mid.ssh.algorithms.host_key​
:   ホスト鍵 SSH アルゴリズムの優先度リストを変更します。プロパティは、カンマ区切りの演算子付きリストを受け取ることができます。リストの名は最も優先度が高く、リストの姓は最も優先度が低くなります。演算子を使用せずにカンマ区切りのリストを追加すると、デフォルトのアルゴリズムリストが置き換えられます。詳細については、「[MID Server SSH 暗号化アルゴリズム](https://servicenow-prod.fluidtopics.net/GNKPfsBu_07rkfmR4NiAYw "MID サーバーは SSH クライアントを利用して多くのディスカバリーアクションを実行します。SSH ハンドシェイクでは、クライアントとサーバーの両方が、最初に双方がサポートするアルゴリズムを決定し、次にクライアントが最も優先度の高いアルゴリズムを選択します。ホストキーアルゴリズムの場合、クライアントは、キータイプに一致する、双方がサポートする最も優先度の高いアルゴリズムを選択します。")」を参照してください。

    * タイプ：文字列
    * デフォルト値：ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,rsa-sha2-256,rsa-sha2-512,ssh-rsa,ssh-dss
    {#r_MIDServerProperties__ul_qdp_pms_xnb}

mid.ssh.algorithms.cifer
:   Cipher SSH アルゴリズムの優先度リストを変更します。プロパティは、カンマ区切りの演算子付きリストを受け取ることができます。リストの名は最も優先度が高く、リストの姓は最も優先度が低くなります。演算子を使用せずにカンマ区切りのリストを追加すると、デフォルトのアルゴリズムリストが置き換えられます。詳細については、「[MID Server SSH 暗号化アルゴリズム](https://servicenow-prod.fluidtopics.net/GNKPfsBu_07rkfmR4NiAYw "MID サーバーは SSH クライアントを利用して多くのディスカバリーアクションを実行します。SSH ハンドシェイクでは、クライアントとサーバーの両方が、最初に双方がサポートするアルゴリズムを決定し、次にクライアントが最も優先度の高いアルゴリズムを選択します。ホストキーアルゴリズムの場合、クライアントは、キータイプに一致する、双方がサポートする最も優先度の高いアルゴリズムを選択します。")」を参照してください。

    * タイプ：文字列
    * デフォルト値：aes128-ctr,aes192-ctr,aes256-ctr,3des-ctr,aes128-cbc,aes192-cbc,aes256-cbc,3des-cbc
    {#r_MIDServerProperties__ul_ehv_pms_xnb}

mid.ssh.algorithms.mac
:   MAC SSH アルゴリズムの優先度リストを変更します。プロパティは、カンマ区切りの演算子付きリストを受け取ることができます。リストの名は最も優先度が高く、リストの姓は最も優先度が低くなります。演算子を使用せずにカンマ区切りのリストを追加すると、デフォルトのアルゴリズムリストが置き換えられます。詳細については、「[MID Server SSH 暗号化アルゴリズム](https://servicenow-prod.fluidtopics.net/GNKPfsBu_07rkfmR4NiAYw "MID サーバーは SSH クライアントを利用して多くのディスカバリーアクションを実行します。SSH ハンドシェイクでは、クライアントとサーバーの両方が、最初に双方がサポートするアルゴリズムを決定し、次にクライアントが最も優先度の高いアルゴリズムを選択します。ホストキーアルゴリズムの場合、クライアントは、キータイプに一致する、双方がサポートする最も優先度の高いアルゴリズムを選択します。")」を参照してください。

    * タイプ：文字列
    * デフォルト値：hmac-sha2-256,hmac-sha1,hmac-sha2-512,hmac-sha1-96,mac-md5-96,hmac-md5
    {#r_MIDServerProperties__ul_hw1_qms_xnb}

Shazzam.chunk_size
:   Shazzam が並列でスキャンする IP アドレスの最大数を指定します。このプロパティは、主に送信ポートの消費を制御します。

    * タイプ：整数
    * デフォルト値： 100
    {#r_MIDServerProperties__ul_dnf_kp2_d3b}

mid.use_net_tools
:   Linux オペレーティングシステムで実行されているデバイスのディスカバリー中に、net-tools コマンドの使用を有効または無効にします。Quebec 以降の ITOM ヴィジビリティでは、ディスカバリーのための iproute2 コマンドがサポートされています。デフォルトでは、ITOM ヴィジビリティ およびディスカバリーパターンは最初に net-tools コマンドを使用し、その後でのみ、フォールバックとして iproute2 コマンドを使用できます。IT ネットワーク内のすべてのベースのデバイスとアプリケーションが iproute2 コマンドを使用している場合は、ディスカバリープロセスをより効率的にするために net-tools コマンドを無効にします。

    * タイプ：true \| false
    * デフォルト値：true
    {#r_MIDServerProperties__ul_p5r_dgx_jnb}

mid.servicewatch.use_full_linux_netstat_path
:   netstat コマンドが完全なインストールパスで実行されるかどうかを制御します。このコマンドは、トップダウンディスカバリーのプロセス検出フェーズ中に Linux サーバーの開いているポートを一覧表示します。

    * タイプ：true \| false
    * デフォルト値：true
    {#r_MIDServerProperties__ul_mk4_tnv_nnb}

mid.servicewatch.num_paths_linux_netstat_to_check
:   Linux サーバーのディスカバリー中に使用するインストールパスの最大数を定義します。このプロパティは、複数の netstat インストールパスがある Linux サーバーでトップダウンディスカバリーを実行し、mid.servicewatch.use_full_linux_netstat_path プロパティが true に設定されている場合に関係します。

    トップダウンディスカバリーは、これらの各インストールパスを使用して netstat コマンドの実行を試みます。最初に成功した実行の結果は、開いているポートのリストを決定するために使用されます。

    * タイプ：true \| 整数
    * デフォルト値： 5
    {#r_MIDServerProperties__ul_khv_s4v_nnb}

mid.servicewatch.use_full_linux_ss_path

:   ss コマンドが完全なインストールパスで実行されるかどうかを制御します。このコマンドは、トップダウンディスカバリーのプロセス検出フェーズ中に Linux サーバーの開いているポートを一覧表示します。

    * タイプ：true \| false
    * デフォルト値：false
    {#r_MIDServerProperties__ul_pzf_ypv_nnb}

mid.servicewatch.num_paths_linux_ss_to_check
:   Linux サーバーのディスカバリー中に使用するインストールパスの最大数を定義します。このプロパティは、複数の ss インストールパスがある Linux サーバーでトップダウンディスカバリーを実行され、mid.servicewatch.use_full_linux_netstat_path プロパティが true に設定されている場合に適用されます。

    トップダウンディスカバリーは、これらの各インストールパスを使用して ss コマンドの実行を試みます。最初に成功した実行の結果は、開いているポートのリストを決定するために使用されます。

    * タイプ：true \| 整数
    * デフォルト値： 5
    {#r_MIDServerProperties__ul_p2m_wpv_nnb}
**関連概念**   

* [MID サーバーのアップグレード](https://servicenow-prod.fluidtopics.net/zkSyiBuxzcO5I4OiMRaVZw "MID サーバーを手動でアップグレードするか、インスタンスから自動的にアップグレードします。インスタンスがアップグレードされ、MID サーバーのバージョンが同じでなくなると、MID サーバーの自動アップグレードがトリガーされます。新しい MID サーバーパッケージが install.service-now.com からダウンロードされ、古いパッケージが置き換えられ、MID サーバーが新しいバージョンで起動します。")
* [MID サーバーダッシュボード](https://servicenow-prod.fluidtopics.net/MnJLTrt~kWbYqTgrORxXTw "MID サーバーダッシュボードは、MID サーバーユーザーが進行中の操作を監視するための中心的な場所です。このダッシュボードは、MID サーバーステータス テーブルの情報を表示するレポートとゲージで構成されています。")
* [MID サーバーファイルクリーナー](https://servicenow-prod.fluidtopics.net/2g7T8y3mZq9ruzzy3XE15w "MID サーバーでは 1 つのモニタースレッドが実行されます。これは、古いファイルをクリーンアップし、インストールフォルダー内のファイルのサイズと量を管理しやすい状態に保ち、MID サーバーのパフォーマンスの問題を防止します。")
* [MID サーバー特権コマンド](https://servicenow-prod.fluidtopics.net/DvO0ND4o6M3nh2O3vGyGQQ#c_PrivilegedCommandsForMIDServer "ホスト サーバー上の特定の情報を検出するには、MID サーバーでより高い権限で SSH コマンドを実行する必要があります。プラットフォームでは、MID サーバーで使用されるデフォルトの特権コマンドと、システムに他のコマンドを追加する機能が用意されています。")  
**関連タスク**   

* [MID サーバーを手動で起動、停止、再起動する](https://servicenow-prod.fluidtopics.net/5vPFqJ7po5JLLYfVw~yKtw "インストール手順の最後で MID サーバー を起動しなかった場合は、MID サーバーを手動で起動することができます。")
* [MID サーバーの JVM メモリサイズを設定する](https://servicenow-prod.fluidtopics.net/DedbqBv_zVnReRnR9grG8A "MID サーバーはデフォルトの JVM メモリ割り当てで開始しますが、この設定は構成ファイルで変更できます。")
* [MID サーバーを一時停止](https://servicenow-prod.fluidtopics.net/TYks0cXOBy6IvF8TO2ALuA#t_PauseTheMIDServer "MID サーバーを一時停止して、作業用の ECC キューをポーリングしたり、検出結果をインスタンスに送り返したりすることを一時的に防止します。")  
**関連資料**   

* [MID サーバーのシステム要件](https://servicenow-prod.fluidtopics.net/OH~buTr0evxAg5Rpk4ClXw "これらの最小システム要件を使用して、MID サーバー をホストするコンピューターにリソースを割り当てます。")
* [MID サーバーの問題の解決](https://servicenow-prod.fluidtopics.net/hl6HWNKssz7E3B6oDTsZ9Q "MID サーバーの問題のトラブルシューティングを行い、解決策を見つけます。MID サーバーを監視して、問題が発生したときにアラートを受信します。MID サーバーの特定の問題を解決するためのトラブルシューティング手順があります。Hi のナレッジベースには、MID サーバーの問題のトラブルシューティングに役立つ記事がいくつか含まれています。")
* [MID サーバーパラメーター](https://servicenow-prod.fluidtopics.net/jmOmC2sAJkDa~pYBu9~Blw#mid-server-parameters "パラメーターは特定の MID サーバーの動作を制御し、MID サーバープロパティよりも優先順位が低いです。")
* [MID サーバー設定パラメーターの設定と優先度](https://servicenow-prod.fluidtopics.net/8zRtD5B1HRCfz_oavudmSQ "MID サーバーの設定は複数のテーブルに存在し、MID サーバーは設定された順序でそれらの設定に優先順位を付けます。MIDConfigParameter は、正しい型スタイルビルダーで定義する必要があります。")
* [MID サーバーで保護されているレコードと予約文字](https://servicenow-prod.fluidtopics.net/TH4ldanqHzFTFSsTBSs~Lg "変更できない MID サーバーレコード一部の特殊文字は XML で事前定義されており、パスワードには使用できません。")
* [MIDSystem メソッド](https://servicenow-prod.fluidtopics.net/39MtVEgMvf~ptBFmVvrLkA "MIDSystem 変数 (変数名 ms で参照される) は、MID サーバーに関する情報を取得するためのさまざまなメソッドを提供します。")
* [MID サーバーのハートビート](https://servicenow-prod.fluidtopics.net/~45rM1JxP5I2FxqQTcpMXg "インスタンスは、代理トランザクションモニタリングシステムを使用して、5 分ごとに MID サーバーの応答を確認します。")

## MID サーバープロパティの作成 {#ariaid-title2}

MID サーバープロパティを使用して、すべての MID サーバーまたは特定の MID サーバーの動作を制御します。

### 始める前に

必要なロール：admin

### このタスクについて

MID サーバープロパティを設定して、MID サーバーパラメーターを上書きします。MID サーバープラグインで MID サーバープロパティを設定します。エージェントの properties フォルダーにある glide.properties ファイルの MID サーバープロパティは設定しないでください。glide.properties ファイルはアップグレード プロセス中に上書きされます。

### 手順

1. 移動先 すべてMID サーバープロパティ.
2. \[新規\] をクリックします。
3. 必要に応じて、フィールドに値を入力します (表を参照)。  
   {#t_SetMIDServerProperties__table_ngk_tld_xp__entry__2}

   | フィールド | 説明 |
   |-|-|
   | 名前 | プロパティ名を入力します。 |
   | 値 | プロパティに設定する値を入力できます。 注: mid.property.jdbc_operations プロパティを使用して JDBC 操作を修正する場合は、BEGIN、END、IF、または一般的な PL/SQL ブロック ステートメントなどの動詞を入力できます。これは、CREATE ステートメントまたは ALTER ステートメントを実行できるようにするために役立ちます。一部のステートメントは、実行する前に MID サーバーを再起動する必要があります。 |
   | MID サーバー | すべての MID サーバーに影響を与える MID サーバープロパティを設定するには、このフィールドを空のままにします。特定の MID サーバーの MID サーバープロパティを設定するには、MID サーバーを選択します。 |
   [表 : 1. MID サーバープロパティのフィールド]

   {#t_SetMIDServerProperties__table_ngk_tld_xp}
4. MID サーバープロパティを設定したら、MID サーバーを再起動してインスタンスとプロパティを同期します。

