---
sourceDocument: オーストラリア ServiceNow AI Platform の機能
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/ja-JP/servicenow-platform

 Release :

    - australia

ft:locale :

    - ja-JP

ft:publication_title :

    - オーストラリア ServiceNow AI Platform の機能

ft:clusterId :

    - platcap

bundleId :

    - platcap

workflow :

    - Platform


---

# アップグレード前の MID サーバーのチェック

# アップグレード前の MID サーバーのチェック {#ariaid-title1}

* リリースバージョン: Australia
* 
* 更新日 2026年04月27日
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 所要時間：10分

アップグレードの前に、MID サーバーはテストを実行して、アップグレードプロセスが失敗したり、MID サーバーが機能停止したりする可能性がある問題を特定します。
各 MID サーバーには、MID サーバーのバージョンとインスタンスのバージョンを比較して MID サーバーのアップグレードが必要かどうかを判断する、AutoUpgrade モニターが含まれています。AutoUpgrade モニターにより MID サーバーのバージョンが古くなっていることが検出されると、その MID サーバーのアップグレード前の検証テストが実行されます。問題が検出された場合は、MID サーバーの問題 \[ecc_agent_issue\] テーブルにメッセージが記録され、アップグレードがブロックされます。AutoUpgrade モニターは、テストにすべて合格するまで 1 時間ごとに実行され続けます。ブロックの原因となる問題がない場合、MID サーバーは適切なアップグレードパッケージをダウンロードし、アップグレードプロセスを開始します。MID サーバーのアップグレード前チェックは、インスタンスのアップグレード時にインスタンスによってトリガーされたアップグレードと、手動アップグレードに対しても実行されます。

## アップグレード前のテスト {#mid-server-pre-upgrade-check__section_xnl_vr1_fqb}

アップグレード前には、必須テストとアラートテストという 2 セットのテストが実行されます。MID サーバーのアップグレードを開始するには、すべての必須テストに合格する必要があります。必須テストに合格しなかった場合、テストはエージェントログに記録され、[MID サーバーのアクティブな問題](https://servicenow-prod.fluidtopics.net/tX4S96aMviJ3YiPT7dhJFg "ServiceNow インスタンスには、MID サーバーの現行の問題を公開し、MID サーバーがリソースを超過する危険があるときにアドミニストレーターに警告する専用テーブルがあります。")が MID サーバーの問題 \[ecc_agent_issue\] テーブルに作成されます。これらのエラーは実際の MID サーバーのアップグレードが行われる前に公開され、アップグレードを続行する前に解決する必要があります。MID サーバーはアップグレードプロセスを停止し、[MID サーバーの状況](https://servicenow-prod.fluidtopics.net/zkSyiBuxzcO5I4OiMRaVZw#c_UpgradeAndTestMIDServer__section_t1p_jc4_1qb) に基づいてステータスを変更します。アラートテストに合格しなかった場合、エージェントログと MID サーバーの問題テーブルにメッセージが追加されますが、アップグレード前のチェックは続行され、MID アップグレードは停止しません。  
アップグレード前の検証テストでは、次の必須テストを確認します。

* 2 GB 以上の空きディスク容量
* ダウンロードサイト (install.service-now.com) へのアクセス
* ダウンロードしたサンプルファイルのデジタル署名の確認
* 実行権限。以下が含まれます。
  * Zip アーカイブをアップグレード一時フォルダー agent/work/upgrade_temp に展開します
  * アップグレードの一時フォルダーからエージェントフォルダーにファイルをコピーします
  * テキストファイルの読み取り、およびコンテンツの検証
  * アップグレード前のチェックコンテンツの削除
  {#mid-server-pre-upgrade-check__ul_b4m_zs1_fqb}
* MID サーバーホストマシンが 32 ビットシステムではない
* Linux MID サーバーでは、glibC のバージョンが 2.17 以上
{#mid-server-pre-upgrade-check__ul_lj5_ws1_fqb}  
Windows MID サーバーでは、アップグレード前の検証で次のアラートテストが実行されます。

* すべての MID サーバーアップグレードブロッカーサービスがホストマシンで実行されている
* ホストマシンでのアプリケーションエクスペリエンスのステータス
* セキュリティのベストプラクティスとして、アドミニストレーター以外のユーザーとして MID サーバーを実行します。MID サーバーの現在の ログオン ユーザーアカウントが LocalSystem であるか、Administrators グループに属するユーザーである場合、アップグレードは失敗しませんが、この構成は推奨されません。
{#mid-server-pre-upgrade-check__ul_hbw_2t1_fqb}

## アップグレードをブロックするエラー {#mid-server-pre-upgrade-check__section_cdl_3t1_fqb}

次のメッセージは、必須テストが失敗したことを説明し、MID サーバーの問題 \[ecc_agent_issue\] テーブルに公開されます。これらのテストに失敗すると、アップグレードがブロックされます。

空きディスク スペースが不足しています。システムにより \<n\> バイトの空きがレポートされています (Not enough free disk space. The system reports \<n\> bytes free)
:   このメッセージは、MID サーバーホストで 2 GB 未満の空きディスク容量が検出された場合に表示されます。このエラーは、MID サーバーのエージェントログにも書き込まれます。

インストールサーバーから更新をダウンロードできません (Unable to download updates from the install server)
:   このメッセージは、MID サーバーホストに install.service-now.com からインストールパッケージをダウンロードする権限がないか、ネットワークの問題により接続が妨げられていることを示しています。このエラーは、MID サーバーのエージェントログにも書き込まれます。

署名の検証に失敗しました：\<メッセージ\> (Signature verification failed:\<message\>)
:   このメッセージは、アップグレード前のチェックでダウンロードしたチェックファイルのデジタル署名を検証しようとしたときに、検証例外が発生したことを示します。

デジタル署名を検証できません：\<メッセージ\> (Unable to verify digital signature:\<message\>)
:   このメッセージは、検証署名プロセスが例外によって中断されたことを示します。

アップグレード前のチェック zip の内容を展開できません (Unable to extract contents of pre upgrade check zip)
:   このメッセージは、MID サーバーホストのサービスアカウントに、アップグレード前の ZIP アーカイブを一時フォルダーに展開する権限がないことを示しています。

フォルダーを作成できません \<アップグレードチェックパス\> (Unable to create folder \<upgrade check file path\>)
:   このメッセージは、MID サーバーのサービスアカウントに、アップグレード前のチェックファイル用の upgradeCheck フォルダーを agent/package パスに作成する権限がないことを示しています。

ファイルの権限を確認できません：\<メッセージ\> (Unable to verify file permissions: \<message\>)
:   このメッセージは、ファイルの権限を確認したときに、存在しないファイルやアクセスの失敗などの例外が発生したことを示しています。

MID Server Windows サービスが LocalSystem またはローカルアドミニストレーターとして実行されていません (MID Server Windows Service is not running as LocalSystem or a local Administrator)
:   このメッセージは、Windows サービスが適切な権限で実行されていないことを警告しています。

アップグレードの失敗：ホストマシンが、MID サーバーをアップグレードするための最小システム要件を満たしていません。(Upgrade Failure: The host machine does not meet the minimum system requirements to upgrade the MID server.)
:   MID アップグレードは 32 ビットホストではサポートされていません。詳細については、[KB0863694](https://support.servicenow.com/nav_to.do?uri=/kb?id=kb_article_view&sysparm_article=KB0863694) を参照してください。

アップグレードの失敗：ホストが、 MID サーバーをアップグレードするための最小システム要件を満たしていません。詳細については、GlibC ライブラリの MID サーバー製品ドキュメントを参照してください。(Upgrade Failure: Host does not meet the minimum system requirements to upgrade the MID server. Please refer to MID Server product documentation on GlibC library for more information)
:   このエラーは、Linux MID サーバーでのみ発生する可能性があります。詳細については、「[Java バージョンのサポート](https://servicenow-prod.fluidtopics.net/OH~buTr0evxAg5Rpk4ClXw "これらの最小システム要件を使用して、MID サーバー をホストするコンピューターにリソースを割り当てます。")」を参照してください。

## ブロックされない警告 {#mid-server-pre-upgrade-check__section_grh_g51_fqb}

次の警告は、MID サーバーの問題 \[ecc_agent_issue\] テーブルに表示され、Windows MID サーバーのアップグレードを妨げません。

$logOnAsUser を解析できません (Unable to parse $logOnAsUser)
:   このメッセージは、Windows サービスの \[ログオンユーザー (Log On As User)\] の値が、次のいずれかの期待される形式になっていないことを警告しています。

    * user@domain.company.com
    * domain\\user
    {#mid-server-pre-upgrade-check__ul_abl_351_fqb}

ログオンユーザーのグループを検索できません (Unable to look up Log On As user's groups)

:   インスタンスは、ログオンユーザーのグループメンバーシップの検索を試みる際に、net user \<username\> コマンドを実行します。インスタンスは、このコマンドから Windows サービスによる特定の出力構造を期待し、期待される出力が実際の出力と一致しない場合はこの警告を発行します。

    これらの PowerShell の警告は、MID サーバーのエージェントログにのみ書き込まれます。PowerShell は MID サーバーを使用する必要がないため、これらの構成の問題は Windows MID サーバーのアップグレードを妨げません。ただし、これらの警告は、注意が必要な環境内の問題を示している可能性があります。

PowerShell が使用できないため、PowerShell のアップグレードチェックをスキップします (kipping PowerShell upgrade checks since PowerShell is not usable)
:   (最低限の) PowerShell 3.0 がインストールされていないか、MID サーバーサービスユーザーが powershell.exe を利用できません。

Powershell テストをスキップ：ターゲットフォルダーが初期化されていません (Skipping Powershell test: Target folder has not been initialized)
:

Powershell テストをスキップ：サービス名を検出できません (Skipping Powershell test: Unable to detect the service name)
:

MID サーバーホストマシンで実行されているサービス CiscoAMP は、MID サーバーアップグレードブロッカーとして識別されます (Service CiscoAMP running on the MID Server host machine is identified as a MID Server upgrade blocker)
:   詳細については、[KB0870329](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0870329) を参照してください。

MID Server ホストでアプリケーションエクスペリエンスが無効になっているため、自動アップグレードプロセスが失敗し、MID サーバーがダウンする可能性があります。自動アップグレードを確実に成功させるには、ホストでサービスを有効にします (The Application Experience is disabled on the MID Server host, which can cause the auto-upgrade process to fail and the MID Server to go down. Enable the service on the host to ensure successful auto-upgrade)
:   詳細については、[KB0597552](https://support.servicenow.com/kb_view.do?sysparm_article=KB0597552#appex&_ga=2.137899701.402632408.1615226320-1555493315.1610383440) を参照してください。

アップグレードを続行しますが、upgradeCheck 中に次の問題が発生しました：\<例外メッセージ\> (Continuing with upgrade, but the following issue was encountered during upgradeCheck: \<exception message\>)
:   このメッセージは、アップグレード前のテストの PowerShell 部分の実行中に問題が発生したことを示しています。

## アップグレード前のチェックの無効化 {#mid-server-pre-upgrade-check__section_by4_w51_fqb}

mid.upgrade.run_precheck という名前の MID サーバーの設定パラメーターは、デフォルトで true に設定されています。これにより、自動的にアップグレード前のテストを実行できます。単一の MID Server でこのテストを無効にするには、その MID サーバーの config.xml ファイルにこのパラメーターを追加して、false に設定します。すべての MID サーバーでこのテストを無効にするには、mid.upgrade.run_precheck という名前の新しいレコードを MID サーバープロパティ \[ecc_agent_property\] テーブルに追加します。このプロパティの値を false に設定し、\[MID サーバー\] フィールドは空のままにします。

