---
sourceDocument: オーストラリア ServiceNow AI Platform の機能
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/ja-JP/servicenow-platform

 Release :

    - australia

ft:locale :

    - ja-JP

ft:publication_title :

    - オーストラリア ServiceNow AI Platform の機能

ft:clusterId :

    - platcap

bundleId :

    - platcap

workflow :

    - Platform


---

# 非 CMDB テーブルの IRE のデータソースルールの作成

# 非 CMDB テーブルの IRE のデータソースルールの作成 {#ariaid-title1}

* リリースバージョン: Australia
* 
* 更新日 2026年03月12日
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 所要時間：3分

識別および調整エンジン (IRE) を使用する場合、特定のデータソースが特定の非 CMDB テーブルの新しいレコードを挿入しないようにすることができます。レコードの作成では信頼しないが既存のレコードの更新では引き続き信頼するデータソースに対して、IRE のデータソースルールを作成します。

## 始める前に

必要なロール:sn_cmdb_admin または itil_admin

## このタスクについて

動的調整ルールが有効な場合、IRE データソースルールは影響を与えません。  
* 子クラスは、識別ルールと同様に、親クラスから IRE データソースルールを派生させます。
* 子クラスに指定された IRE のデータソースルールは、親クラスから派生したすべての IRE のデータソースルールを上書きします。
{#create-non-cmdb-ire-data-src-rule__ul_all_5r1_kjb}  
IRE が IRE のデータソースルールによって禁止されている挿入操作を処理する場合、挿入操作は失敗します。このエラーは、挿入操作および IRE のデータソースルールの、データソースおよびレコードクラスが一致する場合に発生します。[CreateOrUpdateCIEnhanced()](https://www.servicenow.com/docs/access?context=IdentificationEngineScopedAPI&version=australia&pubname=australia-api-reference&ft:locale=en-US) が使用されている場合、IRE は失敗したペイロードを将来の使用に備えて CMDB IRE 部分のペイロード \[cmdb_ire_partial_payloads\] テーブルに格納します。  
注:  
IRE のデータソースルールによって挿入操作が許可されておらず、[createOrUpdateCI()](https://www.servicenow.com/docs/access?context=c_IdentEngineScriptAPI&version=australia&pubname=australia-api-reference&ft:locale=en-US) を使用している場合、[createOrUpdateCI()](https://www.servicenow.com/docs/access?context=c_IdentEngineScriptAPI&version=australia&pubname=australia-api-reference&ft:locale=en-US) は部分的なコミットを許可しないため、IRE ペイロード全体が失敗します。

後で、許可されたデータソースが同じレコードを挿入しようとすると、IRE は部分的ペイロードからの一致するレコードとそのレコードを結合した後に挿入します。続いて IRE は、CMDB IRE 部分のペイロード \[cmdb_ire_partial_payloads\] テーブルから部分的ペイロードを削除し、ルールで指定されたデータソースによる将来の更新を許可します。

IRE データソースルールはルックアップアイテムおよび関連アイテムには適用されず、クラス/データソースのペアに対して有効にできるルールは 1 つのみです。

## 手順

1. 移動先 すべて設定識別/調整IRE のデータソースルール.
2. \[IRE のデータソースルール\] リストビューで \[新規\] をクリックし、IRE のデータソースルールフォームに入力します。  
   {#create-non-cmdb-ire-data-src-rule__table_wfk_yvz_jjb__entry__2}

   | フィールド | 説明 |
   |-|-|
   | データソース | 指定されたクラスの CI の作成を許可されていないデータソースです。 |
   | アクティブ | IRE のデータソースルールを有効にします。 |
   | 適用先 | 指定されたデータソースがレコードの作成を許可されていないクラス (および子クラス) です。 |
   | 許可されていない挿入 | 指定されたデータソースが、指定されたクラスの新しいレコードを非 CMDB テーブルに挿入できないようにします。 |
   [ ]

   {#create-non-cmdb-ire-data-src-rule__table_wfk_yvz_jjb}
3. \[送信\] をクリックします。
{#create-non-cmdb-ire-data-src-rule__steps_nvj_m4f_lvb}

## タスクの結果

ペイロードアイテムに挿入要求があり、データソースとレコードクラスが IRE のデータソースルールで指定されたデータソースとレコードクラスに一致する場合：

1. 挿入操作が失敗し、IRE は次のメッセージをログに記録します。 \[xyz\] への INSERT_NOT_ALLOWED_FOR_SOURCE の挿入は、IRE のデータソースルールによってデータソース \[xyz\] に対してブロックされています。

2. [CreateOrUpdateCIEnhanced()](https://www.servicenow.com/docs/access?context=IdentificationEngineScopedAPI&version=australia&pubname=australia-api-reference&ft:locale=en-US) が使用されている場合、IRE はペイロードアイテムを部分的ペイロードとして CMDB IRE 部分のペイロード \[cmdb_ire_partial_payloads\] テーブルに格納します。

{#create-non-cmdb-ire-data-src-rule__ol_kz4_241_kjb}  
後で、許可されたデータソースが、部分的ペイロードアイテムからのレコードに一致するレコードを正常に挿入した場合：

1. 現在のレコードが部分的ペイロードの一致するレコードと結合され、必要に応じて静的調整ルールが適用されます。
2. CMDB IRE 部分のペイロード \[cmdb_ire_partial_payloads\] テーブルの各部分的ペイロードが削除されます。
3. 許可されていないデータソースがそれぞれのレコードを更新した後のペイロードは、正常に実行されます。
4. IRE を使用すると、以前はレコードの挿入が禁止されていたデータソースが、現在非 CMDB テーブルに存在する同じレコードを更新できます。
{#create-non-cmdb-ire-data-src-rule__ol_esn_wn1_kjb}

