---
sourceDocument: Gestion des opérations IT Xanadu
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/fr-FR/xanadu/it-operations-management

 Release :

    - xanadu

ft:locale :

    - fr-FR

ft:publication_title :

    - Gestion des opérations IT Xanadu

ft:clusterId :

    - itom

bundleId :

    - itom

workflow :

    - Technology


---

# Corriger les erreurs dans les services d'application individuels à l'aide des messages de détection

# Corriger les erreurs dans les services d'application individuels à l'aide des messages de détection {#ariaid-title1}

* Rversion finale: Xanadu
* 
* Mis à jour 1 août 2024
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 6 minutes de lecture

Mappage des services ne propose pas d'options de résolution semi-automatisée des erreurs qui nécessitent une résolution avancée. Corrigez ces erreurs en utilisant les symptômes et les messages de détection.

## Avant de commencer

Essayez de corriger les erreurs à l'aide d'options de résolution semi-automatisée, comme décrit dans [Corriger les erreurs dans des cartes des services d'application individuelles](https://servicenow-prod.fluidtopics.net/YGfVqxE0vUEF4iDN5jaa0A "Vous pouvez résoudre les problèmes de détection individuellement dans chaque carte des services d'application.").
Rôle requis : service_mapping_admin

## Pourquoi et quand exécuter cette tâche

Vous pouvez corriger les erreurs des services d'application individuels à tout moment.

## Procédure

1. Ouvrez la carte de service d'application.
   1. Accédez à ToutCSDMGérer les services techniquesService d'application. {#fix-errors-by-discovery-messages__NavigateCSDMManageTechServiceAppService}
   2. Sélectionnez le service d'application requis.
   3. Sur la page du service d'application, sélectionnez Afficher la carte.
   {#fix-errors-by-discovery-messages__substeps_xxr_jpz_dmb} {#fix-errors-by-discovery-messages__Cmd_NavigateToAppServicesSM}
2. Cliquez sur Afficher la carte en regard du service d'application pertinent.
3. Assurez-vous que la carte s'ouvre en mode d'édition.  

   <br />

   Les CI détectés avec des erreurs apparaissent avec l'icône d'avertissement (![icône d'avertissement]()) sur la carte. Les messages de détection de l'onglet Messages de détection donnent des descriptions d'erreur courtes.
4. Corrigez les erreurs en fonction des symptômes et des messages de détection.  
   {#fix-errors-by-discovery-messages__table_c5n_zmf_jz__entry__2}

   | Symptôme | Résolution |
   |-|-|
   | Le message de détection suivant s'affiche : `la carte n'affiche pas le service en entier, car il est trop grand. Le nombre de connexions de CI a dépassé le maximum autorisé.` | Réduisez la taille du service d'application. * S'il s'agit d'un service d'application mappé à l'aide de la détection basée sur les modèles et basée sur le trafic, effectuez les actions suivantes : * Si vous utilisez des modèles de détection personnalisés et que le mappage entraîne de très grands services d'application, modifiez les modèles afin qu'ils ne mappent pas les CI non pertinents. * [Fractionnez le service en services plus petits](https://servicenow-prod.fluidtopics.net/zzb5ayrIYnoRJJX~F~DG5w "Vous pouvez supprimer une branche d'un service et la placer dans un autre service d'application, nouveau ou existant. Transférez des segments de carte pour fractionner des services volumineux ou lorsque vous souhaitez organiser les services différemment du résultat de mappage initial."). {#fix-errors-by-discovery-messages__ul_dq4_rd2_f4b} * S'il s'agit d'un service d'application converti à partir d'un service d'application, effectuez les actions suivantes : * Examinez le service d'application converti pour identifier les relations CI non pertinentes ou redondantes pour ce service. Supprimer ces relations CI dans la CMDB. * Décidez du nombre de niveaux de CI associés que vous devez inclure dans ce service d'application. Si nécessaire, [modifiez le nombre de niveaux utilisés dans la conversion](https://www.servicenow.com/docs/access?context=update-services-from-cmdb&version=xanadu&pubname=xanadu-servicenow-platform&ft:locale=en-US) pour réduire la taille du service. {#fix-errors-by-discovery-messages__ul_kdh_yh2_f4b} {#fix-errors-by-discovery-messages__ul_fx1_gfd_f4b} |
   | Le message de détection suivant s'affiche dans un service d'application basé sur les balises : This tag-based application service reached the maximum number of CIs. For more information, refer to the product documentation. | Effectuez les actions suivantes : * [Modifiez les définitions de balises utilisées pour le mappage](https://servicenow-prod.fluidtopics.net/2Nc6APlnyL9jPppi~o1DXA "Vous pouvez modifier les définitions de balises utilisées par Mappage des services pour le mappage basé sur les balises. Mappage des services utilise des définitions de balises mises à jour pour créer des services basés sur les balises sans appliquer de changements liés aux balises aux services que vous avez mappés précédemment.") afin de vous assurer que Mappage des services inclut uniquement les CI appropriés dans le service d'application. * Si nécessaire, [configurez la détection basée sur les balises](https://servicenow-prod.fluidtopics.net/FkOyZekEUW0mOZwyN6mh4A "Vous pouvez affiner la configuration par défaut pour contrôler quels CI sont inclus dans les Mappage des services services d’application pendant le processus de détection basé sur les balises.") pour modifier les CI que Mappage des services inclut dans les services d'application basés sur les balises. {#fix-errors-by-discovery-messages__ul_qcv_vtb_jtb} |
   | * La carte des service d'application affiche l'icône d'avertissement (![icône d'avertissement]()) au-dessus ou à la place de l'élément de configuration. * Le message de détection suivant s'affiche pour l'élément de configuration : `échec de l'exécution de la commande à l'aide de sudo sur l'hôte <adresse IP de l'hôte>`. {#fix-errors-by-discovery-messages__ul_hyd_pnm_jz} | [KB0621669 : résolution de l'échec de l'exécution des commandes à l'aide de sudo pendant la détection dans Service Mapping](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0621669) |
   | Le message d'erreur suivant s'affiche pour l'élément de configuration : `l'accès est refusé`. | [KB0564283 : résolution d'un problème d'accès refusé à une instance Windows Server](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0564283) |
   | * La carte des service d'application affiche l'icône d'avertissement (![icône d'avertissement]()) au-dessus ou à la place de l'instance Windows Server. * Le message de détection suivant s'affiche pour Windows Server : `serveur RPC indisponible`. {#fix-errors-by-discovery-messages__ul_qwl_xnm_jz} | [KB0564282 : résolution du problème d'indisponibilité du serveur RPC pendant la détection de Windows Server dans Service Mapping](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0564282) |
   | * La carte des service d'application affiche l'icône d'avertissement (![icône d'avertissement]()) à la place du CI d'équilibreur de charge. * Le message de détection suivant s'affiche : `Service Mapping a déclenché la détection horizontale pour trouver l'hôte x.x.x.x, car cet hôte ne figurait pas dans la CMDB. Échec de la détection horizontale. Pour en savoir plus, reportez-vous à l'état de détection`. {#fix-errors-by-discovery-messages__ul_u4g_b4m_jz} | [KB0610414 : résolution de l'échec de la détection du système d'exploitation pour un équilibreur de charge](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0610414) |
   | À la place de la carte, le message de détection suivant s'affiche : `impossible d'afficher la carte. Topologie trop volumineuse`. | [KB0596671 : résolution d'un problème de topologie volumineuse dans service d'application Cartes](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0596671) |
   | L'adresse IP virtuelle (VIP) d'un CI de service d'équilibreur de charge est parfois mise à jour avec les adresses IP d'un autre équilibreur de charge. | [KB0610412 : résolution de la fusion des équilibreurs de charge en un seul CI dans Service Mapping](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0610412) |
   | La carte affiche des noms d'adresses IP virtuelles incorrects pour les équilibreurs de charge. | [KB0610413 : résolution des noms d'adresses IP virtuelles incorrects des équilibreurs de charge dans Service Mapping](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0610413) |
   | La carte des service d'application se compose de différents CI chaque fois que vous exécutez le processus de mappage sur les mêmes points d'entrée pour détecter le même service d'application. | [KB0595227 : dépannage des résultats de mappage incohérents](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0595227) |
   | Aucun CI d'équilibreur de charge ne figure sur la carte des service d'application. Des connexions vont directement du point d'entrée du service d'application vers les CI du niveau suivant. Le reste des CI disparaît également de la carte. | [KB0621529 : résolution du problème de disparition d'un équilibreur de charge de la carte des services d'application](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0621529) |
   | * La carte des service d'application affiche l'icône d'avertissement (![icône d'avertissement]()) au-dessus ou à la place de l'élément de configuration. * Le message de détection suivant s'affiche pour l'élément de configuration : `expiration de la commande SSH sur l'hôte`. {#fix-errors-by-discovery-messages__ul_bhs_p4m_jz} | [KB0621670 : résolution du problème d'expiration de la commande SSH pendant la détection dans Service Mapping](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0621670) |
   | Un CI de grappe apparaît dissocié de tous les CI dans les niveaux de carte supérieurs ou inférieurs. | [KB0621531 : résolution des CI de grappe déconnectés sur le service d'application carte](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0621531) |
   | * La carte affiche l'élément de configuration (CI) de l'équilibreur de charge avec une icône d'avertissement ou uniquement l'icône d'avertissement (![icône d'avertissement]()). * Le message de détection suivant s'affiche pour le CI qui devrait être l'équilibreur de charge dans le service d'application : `échec de la reconnaissance de l'application. Pour en savoir plus, consultez le journal de détection.` {#fix-errors-by-discovery-messages__ul_s3y_njm_jz} | [KB0621576 : résolution de l'échec de la détection de l'adresse IP virtuelle d'un équilibreur de charge](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0621576) |
   | La carte des service d'application affiche un équilibreur de charge différent de celui que vous vous attendiez à voir dans ce service d'application. | [KB0621616 : la carte des services d'entreprises affiche un équilibreur de charge incorrect dans Service Mapping](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0621616) |
   | * La carte des service d'application affiche l'icône d'avertissement (![icône d'avertissement]()) au-dessus ou à la place de l'élément de configuration. * Le message de détection suivant s'affiche pour l'élément de configuration : `expiration de la commande SSH sur l'hôte`. {#fix-errors-by-discovery-messages__ul_vqk_2km_jz} | [KB0621670 : résolution du problème d'expiration de la commande SSH pendant la détection dans Service Mapping](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0621670) |
   | * La carte des service d'application affiche l'icône d'avertissement (![icône d'avertissement]()) au-dessus ou à la place de l'élément de configuration. * Le message de détection suivant s'affiche pour l'élément de configuration : `MID Server actif introuvable pour l'adresse IP X.X.X.X.` {#fix-errors-by-discovery-messages__ul_vyg_flb_s1b} | [KB0622808 : résolution de l'échec de la recherche d'un MID Server correspondant à une adresse IP](https://support.servicenow.com/kb?id=kb_article_view&sysparm_article=KB0622808) |
   | * La carte des service d'application affiche l'icône d'avertissement (![icône d'avertissement]()) au-dessus ou à la place de l'élément de configuration. * Le message de détection suivant s'affiche pour l'élément de configuration : `<< 64\rctrlx >> n'est pas reconnu comme commande interne ou externe, programme opérable ou fichier de commandes.` {#fix-errors-by-discovery-messages__ul_kkw_kyj_1jb} | Effectuez la procédure décrite dans [Charger le fichier rctrlx.exe vers Serveurs MID](https://servicenow-prod.fluidtopics.net/M8BDmoW52ALaXxbKaBBlqQ "Chargez le fichier rctrlx.exe vers Serveurs MID pour activer l'exécution des commandes de détection sur Microsoft Exchange 2007 et 2010 ainsi que sur Citrix XenApp."). |
   | Un CI ou un segment de la carte est grisé après que Mappage des services a exécuté la détection de haut en bas sur un service d'application précédemment mappé. Dans ce service d'application, Mappage des services n'est pas parvenu à redétecter le CI ou les connexions permettant d'accéder à ce CI. | Procédez comme suit : 1. (Facultatif pour les segments grisés) Identifiez le CI défectueux qui fait que le segment est grisé. 2. Utilisez le message de détection associé à ce CI défectueux pour résoudre le problème. {#fix-errors-by-discovery-messages__ol_v32_hlf_2cb} |
   [ ]

   {#fix-errors-by-discovery-messages__table_c5n_zmf_jz}
5. Cliquez sur Exécuter la détection.
**Tâches associées**   

* [Ignorer les erreurs pour poursuivre la détection d'un service d'application](https://servicenow-prod.fluidtopics.net/wzOBaXeJh21qwU7ULwywSg "Si vous savez quels éléments de configuration (CI) et quelles connexions sont inclus dans votre service d'application, vous pouvez activer Mappage des services pour continuer la détection du service d'application, même en cas d'erreurs. Vous pouvez ignorer les erreurs en remettant à plus tard la résolution des problèmes pour terminer le mappage de la plupart des services d'application, même si certains CI sont manquants.")
* [Résoudre les erreurs de mappage liées au modèle](https://servicenow-prod.fluidtopics.net/nHxgUnyGkdZp5QiwUi_s8w "Vous pouvez résoudre les erreurs de mappage provoquées par des modèles.")

