---
sourceDocument: Australie Workflow Data Fabric
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/fr-FR/integrate-applications

 Release :

    - australia

ft:locale :

    - fr-FR

ft:publication_title :

    - Australie Workflow Data Fabric

ft:clusterId :

    - crint

bundleId :

    - crint

workflow :

    - Creator


---

# Activité de changement du mot de passe utilisateur AD

# Activité de changement du mot de passe utilisateur AD {#ariaid-title1}

* Rversion finale: Australia
* 
* Mis à jour 12 mars 2026
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 2 minutes de lecture

L'activité Modifier le mot de passe utilisateur AD modifie le mot de passe d'un compte utilisateur Active Directory.
Cette activité nécessite le mot de passe actuel de l'utilisateur pour s'exécuter, contrairement à l'activité [Réinitialiser le mot de passe utilisateur AD](https://servicenow-prod.fluidtopics.net/glAqvSrBAsGXvGJXVjGUmw "L’activité Réinitialiser le mot de passe utilisateur AD réinitialise le mot de passe d’un compte d’utilisateur dans Windows Active Directory.") . Si le nouveau mot de passe enfreint des exigences du mot de passe Active Directory telles que la longueur ou les combinaisons de caractères, l'activité échoue et renvoie le message d'erreur approprié. Ce message d'erreur apparaît dans la file d'attente ECC et dans le texte de conseil lorsqu'un utilisateur pointe sur l'activité dans l'éditeur de workflow.  
Pour accéder à cette activité dans l'Éditeur de workflow, sélectionnez l'onglet Personnalisé , puis accédez à Activités personnaliséesActive Directory.  
Remarque :  
Cette activité remplace une activité AD portant le même nom disponible dans les versions précédentes. Si vous disposez d'un workflow qui utilise l'activité déconseillée, votre workflow continuera de fonctionner normalement après la mise à niveau vers Instanbul. Toutefois, tous les nouveaux workflows doivent utiliser la version personnalisée de cette activité, qui a été créée avec le .[Concepteur d'activité PowerShell](https://servicenow-prod.fluidtopics.net/vNicDhQU3ZFd6DCONpaDOA "Les activités PowerShell sont configurées pour renvoyer des données à un workflow à partir d’un hôte à l’aide de Microsoft PowerShell.")

## Variables d'entrée

{#r_ChangeADUserPassword__table_wxp_5kh_dp__entry__2}

| Variable | Description |
|-|-|
| Contrôleur de domaine | Adresse IP de l'ordinateur du contrôleur de domaine. |
| Utilisateur | sAMAccountName du compte d'utilisateur Active Directory. |
| New_password | Le nouveau mot de passe d'affectation de cet utilisateur. |
| Old_password | Le mot de passe actuel de l'utilisateur. |
[Tableau 1. Variables d'entrée Modifier le mot de passe de l'utilisateur AD]

{#r_ChangeADUserPassword__table_wxp_5kh_dp}

## Variables de sortie

{#r_ChangeADUserPassword__table_zqz_ftt_ss__entry__2}

| Variable | Description |
|-|-|
| résultat | L'un des résultats suivants : * échec * réussite * Échec de la politique * Ancien mot de passe incorrect {#r_ChangeADUserPassword__ul_ekn_gsl_zs} |
| errorMessage | Le executionResult.errorMessages du [Sources d'analyse de Concepteur d'activité](https://servicenow-prod.fluidtopics.net/MvPjfPwcbqm1MnFZeco_Tg#r_ActivityDesignerParsingSources "Ce tableau répertorie les sources d’analyse disponibles avec chaque modèle d’exécution."). |
| hresult | Résultat de la commande Powershell. |
[Tableau 2. Modifier le mot de passe de l'utilisateur AD variables de sortie]

{#r_ChangeADUserPassword__table_zqz_ftt_ss}

## Conditions

L'activité fournit les conditions suivantes :{#r_ChangeADUserPassword__table_bdg_krz_ss__entry__2}

| Condition | Description |
|-|-|
| Succès | Mot de passe réinitialisé avec succès. |
| Échec de la politique | Le mot de passe n'est pas conforme aux exigences Active Directory de l'organisation. |
| Ancien mot de passe incorrect | Le mot de passe modifié n'a pas été saisi correctement. |
| Échec | Une erreur s'est produite lors de la tentative de changement du mot de passe. Des détails supplémentaires peuvent être disponibles dans le journal des workflows. |
[Tableau 3. Modifier les conditions de mot de passe utilisateur AD]

{#r_ChangeADUserPassword__table_bdg_krz_ss}

## Informations d'identification Active Directory avec LDAP

Si vous utilisez un serveur LDAP avec des serveurs MID, notez que les activités Orchestration et Active Directory n'utilisent pas le nom d'utilisateur et le mot de passe configurés sur les serveurs LDAP. Vous devez créer un [enregistrement d'informations d'identification d'orchestration de type Windows](https://www.servicenow.com/docs/access?context=r_WindowsCredentialsForm&version=australia&pubname=australia-platform-security&ft:locale=en-US) [Informations d'identification Windows](https://www.servicenow.com/docs/access?context=r_WindowsCredentialsForm&version=australia&pubname=australia-platform-security&ft:locale=en-US). Le nom d'utilisateur et le mot de passe contenus dans l'enregistrement des informations d'identification sont utilisés pour les requêtes LDAP exécutées par Orchestration et les activités de workflow.

