---
sourceDocument: Yokohama Now Platform-Fähigkeiten
sourceDocumentLink: https://servicenow-prod.fluidtopics.net/r/de-DE/yokohama/servicenow-platform

 Release :

    - yokohama

ft:locale :

    - de-DE

ft:publication_title :

    - Yokohama Now Platform-Fähigkeiten

ft:clusterId :

    - platcap

bundleId :

    - platcap

workflow :

    - Platform


---

# PowerShell-Fehlerbehebung

# PowerShell-Fehlerbehebung {#ariaid-title1}

* Freigeben Version: Yokohama
* 
* Aktualisiert 30. Januar 2025
* 
* ![](https://www.servicenow.com/docs/portal-asset/ico-clock) 2 Minuten Lesedauer

Fehler bei „Authentifizierung und Zugriff verweigert" können verhindern, dass PowerShell-Aktivitäten einen Befehl auf einem Zielhost ausführen.  
Verwenden Sie diese Verfahren zur Behebung von Authentifizierungsfehlern bei Orchestration-PowerShell-Aktivitäten und wenn der RPC-Server (Remote Procedure Call) nicht verfügbar ist oder der Zugriff verweigert wird. Der Authentifizierungsfehler wird angezeigt, wenn alle Anmeldeinformationen, einschließlich der des lokalen MID-Server-Service-Accounts, nicht über die richtigen Berechtigungen zum Ausführen des Powershell-Skripts/-Befehls verfügen. Derselbe Fehler wird angezeigt, wenn der Zielhost nicht erreichbar ist. Abbildung : 1. Authentifizierungsfehlermeldung

## Authentifizierungsfehler in einer Active Directory-Aktivität {#ariaid-title2}

In diesem Beispiel wird die Aktivität „AD-Objekt erstellen" verwendet, um die Behebung von Authentifizierungsfehlern in PowerShell zu veranschaulichen.

### Vorbereitungen

Erforderliche Rolle: Berechtigungen für den Zugriff auf und die Erstellung von Accounts in Active Directory

### Warum und wann dieser Vorgang ausgeführt wird

Überprüfen Sie, ob der von Ihnen verwendete Account über die richtigen Berechtigungen zum Ausführen der Aktivität verfügt.

### Prozedur

1. Melden Sie sich mit dem Account, unter dem Sie die Aktivität ausführen möchten, beim Zielcomputer an.  
   Active Directory-Tools müssen auf diesem Computer installiert sein.
2. Starten Sie die Active Directory-Anwendung „Anwender und Computer".
3. Navigieren Sie zur OE, unter der Sie das Active Directory-Objekt erstellen möchten.
4. Versuchen Sie, das Objekt zu erstellen.  
   Wenn dieses Verfahren unter dem angegebenen Anwender erfolgreich ist, kann Folgendes die Ursache für den Authentifizierungsfehler sein:
   * Anwendername ist ungültig.
   * Passwort falsch eingegeben.
   * Domänencontroller ist nicht erreichbar.

   {#troubleshoot-ad-auth-failure__ul_yvw_zlr_dw}  
   Hinweis:  
   Die Mehrheit der Rückgabecodes, die im MID-Serverprotokoll für diesen Fehler aufgeführt sind, ist 1 S und 3 S. Dies liegt daran, dass die Active Directory-Aktivitäten den ADSI-Anbieter und nicht WMI oder WinRM verwenden. Ein Fehlercode von 1 Bedeutet, dass der Account eine Verbindung zum Test-Account herstellen konnte, das Ausführen des Skripts ist jedoch fehlgeschlagen.  
   Ein Fehlercode von 3 Bedeutet, dass der MID-Server versucht hat, die PowerShell-Aktivität unter dem MID-Server-Servicekonto auszuführen, aber fehlgeschlagen ist.

## Authentifizierungsfehler in einer Exchange-Aktivität {#ariaid-title3}

In diesem Beispiel wird die Aktivität „Postfach erstellen" verwendet, um die Behebung von Authentifizierungsfehlern in PowerShell zu veranschaulichen.

### Vorbereitungen

Erforderliche Rolle: Berechtigungen für den Zugriff auf Postfächer und das Erstellen von Postfächern auf dem Exchange-Server

### Prozedur

1. Überprüfen Sie, ob der von Ihnen verwendete Account über die richtigen Berechtigungen zum Ausführen der PowerShell-Aktivität verfügt.
2. Melden Sie sich bei einem Computer an, auf dem die Exchange Management Shell (EMS) installiert ist.
3. Erstellen Sie einen Anwender mit `New-Mailbox `Exchange-Befehl.  
   Abbildung : 2. Erstellen eines neuen Anwenders in Exchange  
   Wenn dieses Verfahren unter den angegebenen Anmeldeinformationen erfolgreich ist, ist die wahrscheinliche Fehlerursache:
   * Anwendername ist ungültig.
   * Passwort falsch eingegeben.
   * Exchange-Server ist nicht erreichbar.
   {#troubleshoot-exchange-auth-failure__ul_yvw_zlr_dw}
4. Wenn der Exchange-Server nicht erreichbar ist, überprüfen Sie die MID-Serverprotokolle.  
   Da die Exchange-Aktivitäten WinRM für den Zugriff auf den Exchange-Server verwenden, können die Protokolle weitere Informationen zur Fehlerbehebung bereitstellen.  
   Hinweis:  
   Stellen Sie sicher, dass der Fehler NICHT ist WinRM kann die Anforderung nicht verarbeiten .

## RPC-Server (Remote Procedure Call) nicht verfügbar oder Zugriff verweigert {#ariaid-title4}

Normalerweise wird dieser Fehler protokolliert, wenn ein PowerShell-Skript/-Befehl ausgeführt wird, das WinRM oder WMI verwendet.

### Mögliche Fehlerursachen

Der Zielhost kann eines der folgenden Probleme haben:

* WinRM ist nicht konfiguriert.
* Firewall blockiert den Zugriff auf den Host über TCP-Port 135 (WMI) oder HTTP/HTTPS und TCP-Port 5985 (WinRM).
* Kerberos-Problem, verursacht durch Hopping zu mehreren Hosts mithilfe von WMI.
{#rpc-server-unavail-access-denied__ul_f1z_ptr_dw}

### Beispiel für WinRM-Fehler

Die Aktivität „Postfach aus dem Exchange-Aktivitätspaket erstellen" hat einen Fehler in der ECC-Warteschlange generiert, bei der die Authentifizierung mit den Anmeldeinformationen des MID-Serverservice erfolgt. Dies ist aufgetreten, da die Anmeldeinformationen des MID-Servers die letzten sind, die verwendet werden sollen, wenn der Zielhost nicht der MID-Server ist.Abbildung : 3. Fehlermeldung für Authentifizierungsfehler  
Das MID-Serverprotokoll zeigt an, dass der MID-Server versucht hat, die Aktivität unter bestimmten Anmeldeinformationen auszuführen, aber nicht erfolgreich war und den Exit-Code 1 erhalten hat.Abbildung : 4. MID-Server-Fehlercode

